NaturalONE web page --> refer to

A new web page has been designed for NaturalONE.
You can find a lot of general information, tutorials and videos.
You have the ability to download NaturalONE Community Edition free of charge.

Is there a problem with your server handling the load?

It took hours for the download request to complete, stalling many times, so that I had to monitor progress and prompt it to continue.

Download of the full version (20 times the size) was much quicker, evidence that the problem is not at my end - but this is by no means conclusive.

Hi Ralph,

Sorry for the inconvenience this caused. We will check what happened.

The NaturalONE Community Edition is about 1 GB large, but it should not take hours to download.
What do you mean by “full version (20 times the size)”?


Hello Ralph,

We are currently looking into the problem with the slow download and we’ll follow up with information shortly.

Best regards,
Community Team

Sorry, Michael. Including documentation, the full product download is 2G (not 20), which is twice that of the Community Edition. It must have been my impatience with the CE download that clouded my memory. The full download was quick in comparison.

Again, my apologies for my error.

I have downloaded NaturalOne yesterday evening and installed it, which took quite long. But when I finally was ready to start the program (Software AG Designer 8.0 or something like that, as described in the Getting Started document), nothing happened.
I tried it several times, even removed my existing Eclipse, but no success.
Then I uninstalled it. I should rather have got myself a bit more sleep instead :wink:

Did anybody encounter the same problems? What could the reason be?
My operating system is Windows XP professional.
Thanks in advance for your advice. I’d really like to try this out.

the problem might be that an existing workspace was picked up by NaturalONE. NaturalONE uses “:\Documents and Settings<user>\workspace” as default name and location.

If you decide to re-install, please make sure that the NaturalONE-CE installation folder was removed.

I’ve just tried it again, with the same result.
I had already removed Eclipse and the workspace, and I have also removed the folder C:\NaturalONE-CE before reinstalling, as suggested.
Could the reason be that I saved and extracted the downloaded file to my D drive, but selected the C drive at the start of the installation?
Should I delete the folder extracted from the download and start all again?

The phenomenal interest in NaturalONE unfortunately created slow download times for some of you. We apologize for this inconvenience and have now resolved the issue.

We have sent a detailed e-mail to all of you who may have experienced the problem before March 5th.

Hi Eva,
please check if there where errors during the installing by scanning the installLog.txt in \NaturalONE-CE\install\logs for the string APP_ERROR>.

You say nothing happens when you start NaturalONE from Start>All Program>NaturalONE Communitiy Edition>Tools>Software AG Designer 8.0 - don’t you even see the screen to select a workspace?

Please also have a look in \NaturalONE-CE\eclipse\v34\configuration for files with the extension .log. If there are such files you may find information about the problem there.


Hi Gerhard,
thanks for your reply.

I only found the following line in the file installLog.txt:
“To find product error messages, search for the string APP_ERROR”

No, I don’t.

C:\NaturalONE-CE\eclipse\v34\configuration\org.eclipse.update\install.log doesn’t say anything about any error, there are only success messages.
Then there is a file error_recovery.log in the same directory, but this doesn’t mention any error either. In the end it says “LogEntry.7=ALL_FEATURES_INSTALLED”

Thanks in advance for your ideas

C:\NaturalONE-CE\eclipse\v34\configuration\config.ini contains a line

“osgi.instance.area.default=@user.home/workspace” .
This seems to be a variable- probably it contains some wrong value causing that Eclipse does not ask me for the workspace any longer?
How can I find out the content of this variable?

NaturalONE uses the config.ini in \NaturalONE-CE\eclipse\v34. You may want to check if it contains strange entries.

I suppose you also do not see the Software AG Designer splash screen when you start NaturalONE?

Thanks Gerhard,

There is no config.ini in the directory \NaturalONE-CE\eclipse\v34.
There’s only an ‘eclipse.ini’, with the following content.

I’m not quite sure whether this is as it should be, being not familiar with Eclipse.
Would it possibly help to copy the other config.ini in this directory?
If not, would it be possible to send me a config.ini which I could put into this directory and adjust (if needed ) ?

No I don’t.

Sorry Eva, I mixed the two ini files. Both are ok in your installation. Actually, as far as I see, the installation itself seems to be ok. I have to look for an Eclipse specialist to further narrow down the problem.

Hi Eva,
sorry for coming back late -
we had similar problems on some smaller machines and found that changing the MaxPermSize parameter in the file from the current value of 256m to lower values like 180m solved the problem.

Hi Gerhard, thanks very much for your help! After changing the MaxPermSize parameter to 180m, I could start the application.