NAT0909 error in Prod but not Development-very odd

We are calling an external webservice from Natural online and using the Java XML RPC Server (EXX 7.2). When we upgraded our development environment Natural to version 4.1.04 Nat0909 showed up when we hit the callnat to the external webservice. Per the docs, we bumped up the DATSIZE to 200 and the call now works fine.

When we upgraded our production environment to Nat 4.1.04 we saw the same Nat0909 when calling the external webservice and again increased the DATSIZE but it did not resolve the nat error no matter how large the DATSIZE was increased. We still get the Nat0909.

Now for the odd part: We can get it work in production in certain instances. The callnat module can be called in 2 ways during the user work flow. One branch works in production and one branch gives the Nat0909. Both branches work fine in our development environment. Development and production code and artifacts are identical. Here is what is happening:

A. Prog1-> SubP1-> SubP2-> SubP1-> SubP3 (Callnat module)->Prog1 This sequence works in development and production.

B. Prog1-> SubP1-> Subp3 (Callnat module)->SubP1 ->Prog1
This sequence works in development but gets a Nat0909 in production.
This sequence works in production when in DBUG mode.

C. ProgTest1 -> SubP1-> Subp3 (Callnat module) -> ProgTest1
This sequence works in production when ProgTest1 is executed.

We have opened a Request with SAG (#693538) but I thought I would throw it out here to see if anyone has seen this before when calling an external webservice from Natural.

Thanks,
Chris

Problem solved-
Our production Natural nucleus was pointed at the development FNAT and only brought in the DATSIZE from development, which wasn’t large enough.