MWS Monitor

Hello,

Company I work for is currently using MWS version 7.1.2.0.112. Just recently, end users and myself is not able to access the Monitor module. When trying to access the monitor page, the page never loads. Everyone is able to login and access the Administrator module and pages. Checked the system.out log and do see the msg processing request then nothing afterwards. No errors. Has anyone seen this before or know where else I can look to get more information on what may be causing this? Thank you very much.

If that page fails to load, I would expect to see some web service exceptions recording in the MWS full.log. Otherwise we don’t have much information to diagnose your problem with.

Note: MWS 7.1.2 is no longer a supported version of MWS unless your company is on an Extended Maintenance plan. If they are, I would raise this issue with Customer Support.

Hello Ron,

Thanks for the quick response. Checked the log file and do see the errors below in the full.log file. I’ve also increased the connection timeout and still the same problem. Thanks.

java.rmi.RemoteException: java.net.SocketTimeoutException: Read timed out; nested exception is:
java.net.SocketTimeoutException: Read timed out
electric.registry.RegistryException: could not bind to path: http://:/services/processModel.wsdl
java.net.MalformedURLException: Malformed URL http://:/services/processModel

The MalformedURLException shows that your MWS is not properly configured with the target Optimize server name.
Notice the blanks in the http://:/services/processModel. It should look more like http://myintegrationserver:5555/services/processModel.

Check your configuration in the System Settings page to provide the target Integration Server information.

Would that be in the Administration > My WebMethods > System Settings?

Yes

Currently the setting is localhost. Checked the test environment where it is working correctly and it has the same setting of localhost. Tried using the machine name and ip address and no luck. Could the malformed url msg be caused by the socket read timeout errors seen before the malformed error in the log file? Maybe there is something not being able to be read causing the malformed url message? Any thoughts on what needs to be read?

Unfortunately, I’m not that familiar with the internals of that portlet so I couldn’t say if the socket read is related.
If you have an Extended Maintenance contract for MWS 7.1.2, I recommend raising the issue with customer support.

Thank you Ron for all your help on this. I ended up just re-installing mws and it’s working now. Again Thank you so much for your help.