Migration from 7.1.3 to 8.2.2 Trading Network Issue

I am having trouble migrating the Trading Networks components using the database configurator. My bizdoc tables are missing columns. When I attempt to migrate I get a message stating “Trading Networks is not installed. Please install the component using the create action”. Then when I attempt to to use the create action to install I get a message stating “Name of Object to be created identical to existing.” So the install fails. Any ideas on how to move forward past this issue?

I don’t think you had used dbConfigurator scripts to migrate 7.1.3 tables to 8.2.2, do you? The table structures might differ between different versions, hence the bizdoc tables are missing columns.

If you could list the steps you followed to migrate TN data from 7.1.3 to 8.2.2, we can analyze more and get into the details of why this error appeared.


We made copies of our 7.1.3 databases to use for the 8.2 upgrade. During the upgrade we referenced the newly copied databases. Then the problem started. We have since dropped and created the tables and we don’t have the issue anymore. But we also don’t have our data, we ran the migrate script but it did not populate the document types, processing rules, etc… What is the best way to get that data from our 7.1.3 TN database to our 8.2 database.

You tried to use copies of 7.1.3 database with 8.2 product, hence it did not work (as expected). You had dropped 7.1.3 tables, and created 8.2 tables, hence it worked with 8.2 product (as expected). :slight_smile:

Follow the below steps…

  1. Take a copy of 7.1.3 database
  2. Before even you point this database with 8.2 suite, the tables should be migrated to 8.2 version.
  3. Use dbConfigurator.sh/.bat commands (Refer 8_2 Upgrading webMethods Products suite documentation)

Eg,. dbConfigurator.sh -a migrate -d oracle -c tradingnetworks -v latest -l dbURL -u user -p password

You should execute this dbConfigurator command from 8.2 server’s installation directory as it has the scripts along with DB Component configurator installed with it.

For TN, you should supply ‘tradingnetworks’ and ‘tradingnetworksarchive’ to migrate all TN related tables.

To know what tables exist in your existing database, you can use the ‘catalog’ keywork of dbConfigurator which will tell you about existing tables.

Eg., dbConfigurator.sh -a catalog -d oracle -l dbURL -u user -p password

Once the dbConfigurator migrates all your tables to the latest, you could point the TN JDBC pools from IS to connect to this migrated database. You should see all assets of TN.



Eg,. dbConfigurator.sh -a migrate -d oracle -c tradingnetworks -v latest -l dbURL -u user -p password

dbURL -u user -p password

Which db url/user/pwd need to give in that step is that 713 or 822 (new db)?

I have not tried this command route yet.so just clarify:


There is no need of maintainig old database 7.1.3 along with new database by executing create scripts (fresh install).

We have to take backup of 7.1.3 and restore it with a different name… On this new named database schema, we got to execute the migration scripts either using db configurator UI or command line mode. This new schema will get migrated to 8.2.2 version as all its tables, and associated data is now migrated using the scripts… This new migrated schema will not work with 7.1.3 now, and it works only with 8.2.2 suite…

In case if it throws any error, we have to delete the entire schema/db in which we tried to execute migration scripts, restore with the old one thru’ backup with new name again, and execute the migration scripts after fixing the encountered problem…

Pls let me know if this clarfies your query…


I am not asking the old db 713 maintaining…thanks for the clarity info.


Running migration scripts from 713 to 822, as you said it failed. Please verify if your using TN_Fix_7 or higher, you need to comment out dbo.BizDoc, create index for Native ID and GroupID and some ArchiveService tables…These are suggested by softwareAG guide…

The above info you mentioned only applies to if you have TN_Fix_7 fix installed?

BTW,What fix are you saying can you tell exact fix number ie TNS Core Fix7?