MFT Virtual Folder connecting to a Window server with folder that have spaces

Hi Experts,

I am using Manage File Transfer deployed to a Unix directory to connect to a Windows. I am trying to establish connection from virtual folder. If i connect just from the server itself i am able to connect successfully. But if i add the directory which have spaces to it, its not working saying invalid directory. (e.g. C/Program Files (x86). I have already tried adding a double quote to wrap around the directory path but it did not work.

Example:
This one works:
SFTP://anywindowserver:22/C/

But these ones does not work:
SFTP:://anywindowserver:22/C/Program Files (x86)/
SFTP:://anywindowserver:22/“C/Program Files (x86)”/

What product/components do you use and which version/fix level are you on?

Is your question related to the free trial, or to a production (customer) instance?

What are you trying to achieve? Please describe it in detail.

Do you get any error messages? Please provide a full error message screenshot and log file.

Have you installed all the latest fixes for the products and systems you are using?

Hi Paul,

do you really require a path which contains spaces in this scenario?
It might be better to choose a path which does not contain spaces here.

Regards,
Holger

Have you attempted to use quotes around the name? Possibly you might be able to use the short name assigned. The short names can be viewed using dir /x. On my machine, PROGRA~2 is the short name for Program Files (x86) on my C: drive.

1 Like

Hello Reamon,

Yes i have tried wrapping it with quotes but it did not work. Is this short name assigned, is being configured on the window server side?

Hi Holger,

Unfortunately we had to. Some requirements from the end system.

Yes, the short-name is something the Windows automatically does for long-named directories. You’ll want to confirm what it is specifically for the server you’re connecting to.