Metadata Library 7


We are trying to use the Metadata library. I have installed and configured it and I can publish to it from Integration Server and see the database being updated. So I am happy that it is working correctly.

What I can’t figure out though is how do you retrieve from the library? I can’t find anything in the documentation or see anything on the Integration Server \ Asset Publisher screens.



Hi Debbie do you mean with retrieve from the library, in what enviroment¿? the idea is to publish the IS assets to reuse them from the Designer tool and reuse them inside the Business process. Did you tried it?

For the IS enviroment you only can publish to the DB or retract those assets, but only for being used by Designer.

I hope this helps.

From the documentation it seems that you should be able to retrieve your packages in the metadata from integration server, otherwise how would you be able to share these packages with other servers?

For designer I thought it would be just for portlets and processes, I also can’t get the metadata library working in designer either. I can publish to it but if I refresh the view of the metadata library nothing shows up, and if I search it I don’t get anything either.

I am running Wm7 SP2 with all the latest components and I have them all installed locally on my XP machine.

Thanks for your help


Well also exist deployer to share IS packages.

It happens to me too at the beginning, try two things:

  • Once you already have published the IS assets using asset publisher, and configure in the designer the metadata library (I suppose that is already done because you tried to publish portlets and Designer assets, right?), well after that, open an existing Business process or create a new one, and in the receive step, in choose documento, try to use Metadata Library rather than Is browser, also do that with a invoke step, create a new blankk invoke step and in the implementation select a service from the metadata library, after that, refresh the Metadata Library view.

  • following the indications from Premesh Purayil:

Just to be clear here are the steps to follow to properly upgrade a workspace to 7.1.

  1.   Shutdown Designer.
  2.   Remove the folder located at %WORKSPACE%\.metadata\.plugins\\.stores\Local  - contains the local library derby database from previous extractions.
  3.   Restart Designer – This will copy a new 7.1 empty library into your workspace
  4.   Close and open every project in your workspace – this will cause every project to re-extract their assets.
  5.   Try publishing an asset 

good luck


Thanks again for your response.

I had created a new workspace like you said and I had imported the projects in. I have tried deleting the files you suggested, and then open and closed the projects.

I then tried to create a new model as you said but unfortunately I am still not seeing anything in the metadata library. But it is definitely publishing to it as I can see them in the database.