Major Issue with the IS

hi all,
I am working on webM 8.0.
By mistake i edited the Access Mode of the Primary port in Security -> Ports tab in the IS Admin page as Deny be default.

Now the entire access to that server, developer is denied.
Can somebody suggest how to revert it to the normal state.

I am getting an error like this.
Access Denied.

Services necessary to show the Integration Server Administrator are currently unavailable on this port. This is most likely due to port security restrictions.

If this is the only port available to access the Integration Server, contact webMethods Support.

Can somebody help me with this.

Regards,
Krithiga M

You can still access IS Admin page if you have the diagnostic port 9999 enabled. From there you can reset the access to the primary port. Can you try http://servername:9999 and see if you get access to the Admin page?

Or you can restore from IntegrationServer/config/backup all the ACL* files and start IS again, then you will get the same ACL’s before the last backup was done.

:smiley:

In 6.5 it is the port.cnf file in config folder that gets updated when you make any changes in the ports section. So you can try including port.cnf file too when you restore from backup as DevNull suggested if it is the same in 8.0.

Hi all,
Thanks for all your replies.
We dont have the back ups of the files.
We did not know the diagnostic port then. But we know it now after a great lesson :slight_smile: the diagnostic port was different for us.
But we managed to solve the problem by killing the process and restarting the IS with a different port number and changing the primary port again.

This worked out.
Thanks again,
Krithiga