listFiles - not allowed in subdirectories

Hi facing the following problem, I’ve a service. This service is invoked by the scheduler and the service reads a directory where I expect xml and wav files.
I add the directory which I want to read from to the fileAccessControl.cnf.

The problem I have is that the content of the files are stored in a directory itself which are dynamically created.
This means


I add the c:\myDir\expectingContent to the fileAccessControl.cnf
The directory T08062015;11370233 is dynamically created so I can’t add this to fileAccessControl.cnf

In the documentation is stated:

What do I need to do that subdirectories are also allowed?
I tried with a wildcard what didn’t work.
Please advise

Regards Dirk

Your IS version and fix levels?

Did you try


Hi we have IS Version 9.5.1

I tried the following construction in my configuration file without any success:


I put 2 backslash infront of the semicolon, this is written in the Manual.
I can’t use the Name fo the file becasue this is also dynamicaly created

Our fix Level

I think there is a fix suggested by SAG if the wildcards(*) is not working in config file. Meanwhile raise a ticket, if I find other alternate solution I will post you.

Keep me informed about this issue please.

Opend a ticket, hoping for a solution.

Did you reload the WmPublic package after your change in the config. Try if the below works.




Just a note from the docs
"You can use the wildcard character asterisk () to match multiple folders, subfolders,
and files. A single asterisk (
) wildcard can be used to denote single directory names.
Double asterisks () can be used to denote multiple files and subfolders in a folder.
For example, the following entry will allow the services in pub.file folder to write to
all the .log files in the first subdirectory whose name start with ‘fatal’ in the c:/home/
The following entry will allow the services in pub.file folder to write to all files in all
the subdirectories of c:/home directory: