Large Document recognition Issue using

Dear wmusers,

Our partner is submitting a compressed large file to on HTTP protocol and TN recognizes the content
as largepart and invokes processing service.In processing service I decompress the content and then resubmit the uncompressed XML
content back to TN for further processing but this time TN is not recognizing the content as large.
I am using to route the xml back to TN.I have set my TN large file config setting correctly as it works when content is submitted first time using HTTP.

Can someone suggest why would would not recognize my doc as large? Node I supply to routeXml
service is being contructed via stream input to pub.xml:xmlStringToXMLNode.

I tried using for internal submit but it’s behavior is same as routeXml.

IS: 7-1-2_Core_Fix14


It is the HTTP handler that determines if a doc is large, not routeXml. Submit the doc using pub.client:http being sure to set the content-size header.

As Rob suggested above,yes use the pub.client:http (method=post) and invoke the with header/content-size setting.


It is unfortunate that in order to submit to local server, I have to use HTTP.Don’t you expect it to have performance implications? A work around I have figured out is If I construct a $reservation object before calling routeXML then the document is being recognized as large.

“Don’t you expect it to have performance implications?”



are you saying that TN will never recognize the document as large if document is sent using routeXML ?

i have successfully set up TN large document handling for documents which were routed using routeXML inbuilt service.

Once document is routed to TN, tn.BigDocThreshold is the factor which would decide whether the document would be considered as large or not, irrespective of routing mechanism.

can you try setting bigDocThreshold value to 0 which would mean that all document routed to TN would be considered as large.

That’s been my experience. But it has been a while since I’ve tried it.

Hi everyone,

I have tried doing that but its not working.I am sending a 3MB document to TN but Tn is not recognizing that document as large.
I have used the following settings:-

tn.BigDocThreshold = 0
tn.xml.xqlThreshold = 5000

To send the document to Tn i am using Following services:-


Plz help its urgent

Thanks in advance,

Chinmaya Nanda

You should try using receive or routeXML (prefferred) service for routing doc to TN and not http for internal processings.


First try with smaller chunks data and if recognition works then use large file.You can also test xml submission via WmTN Home page


chinmaya, I believe the content-size header must be set for large doc handling to kick in.

But it appears that your steps are already loading the entire document into memory so there is no point in trying to get large doc handling of TN used until you restructure things.

Hi rmg/reamon,
I have tried using routeXML also but that is also not working.As i was going through the documentation i found that we cannot send a large document by $xmlData.Therefore i was using client:http but that is also not working.
Can u guys plz send me the code how to route a large document to TN???My email id is

Thanks in advance,

Chinmaya Nanda

Did you also tried thru http://yourIShost:5555/WmTNWeb/ from DocumentSubmission page?

Did you also see Rob’s comments?


Can you post the service steps along with parameter details? Perhaps we can see what is amiss.

But I want to emphasize again that if you’ve already loaded the document into memory (you mentioned using a couple of services that will only work when the document is completely in memory) then trying to get large doc handling for TN is pointless.

Hi rob/rmg,

Thanx for your prevoius replies :).

I have used following services.I m sending u the screenshots.

I have used the following settings:-

tn.BigDocThreshold = 0
tn.xml.xqlThreshold = 5000

Please tell me what i am doing wrong.

Thanks in advance,

Chinmaya Nanda

Hi guys,

These are all the screenshots :slight_smile:


Chinmaya Nanda

I’ve mentioned it before in this thread–routeXml will not cause large document handling to be used.

If the screenshot of the call to routeXml is for the service that is intended for real use (instead of just a “test things out” service) then the documentToXMLString and xmlStringToXMLNode are also a problem–those services expect the entire document to be in memory.

If you want large doc handling:

  1. Don’t load the entire document into memory at any point of the integration. Use node iteration if necessary.

  2. Use http to post the document to TN. Be sure to set the content-size header and pass a stream to the http call, not bytes nor a string.

I’ve mentioned it before in this thread–routeXml will not cause large document handling to be used. --> My intention is not use routeXML (only to test stuff or internal routings).For large document handling purpose always Node iteration/http call and configure IS/TN LargeDoc handling is preferred way.


Hi rob/rmg,

           Sorry for late reply.finally I am able to do the large document handling.Thank you guyzzz for your support and answers.I will upload a document regarding what i have done  soon.

Thanks again Guys.

Thanks and Regards,

Chinmaya Nanda

Great thanks for the update!

HI puneet,

i have set following configuration values in TN


Now i tried to check whether Large document handling is working or not by invoking these steps

then routeXML to route it to TN

while i m seeing the document has been sent to TN but in the pipeline out of the handleLargeDoc step
i m seeing under the bizDoc section LargeDocument is false i.e it is not recognised as large document…Can u please share steps that u have taken to send large document to TN