jdk 1.3 vs jdk 1.3.1

hi webdav gurus :wink:

I’m experiencing some installation problems with webdav.

My configuration :
- win2000 pro
- iis installed and running (tamino xml server - starter kit - uses iis and works fine)
- Apache Tomcat 4.0
- jdk1.3.1
- j2eesdk1.3
- jdk1.3 (part of JBuilder 4)

When installing webDAV 3.1.1, the installation process automatically uses the jdk1.3 found in JBuilder 4.

If I edit the registry so that jdk1.3 is hidden (renamed 1.3 into something else), the installation process points to \Common Files\Software AG\jre 1.3.

However, the install.txt says that a fully installed JDK or JRE 1.3.1_01 is required …

My question : is it correct that the install processus chooses a jdk 1.3 ?

Once installed, if I want to start the server (inodavserver start), I get the following error :

configWrapper:
[copy] Copying 1 file to C:\Program Files\Software AG\Tamino\Tamino WebDav
Server 3.1.1\jakarta-tomcat\conf\jk
[exec] System error 1060 has occurred.
[exec]
[exec] The specified service does not exist as an installed service.
[exec]
[exec] Result: 2
[exec] The service name is invalid.
[exec]
[exec] More help is available by typing NET HELPMSG 2185.
[exec]
[exec] Result: 2

However, I have done a “inodavconfig install service” which looks good … but does this work only for apache ?

As you see, I’m a little confused and would appreciate very much your help.

Thanks in advance and best regards,

R

Hi,

if you use Java prior to 1.3.1_01 Tamino WebDAV Server (TWS) won’t start as a service. For workaraound see 1.6 in the readme. No other problems known currently with elder 1.3 versions.

Perhaps that was already your problem, that the service does not seem to be correctly installed. Please have a look into your …\jakarta-tomcat\logs directory, in one of the nt-service logfiles there should be a message, that option -rs is not recognized.

Do you see TaminoWebDAVServer in your services list?

Regards,
Martin

Hi Martin,

Thanks for your reply.

:slight_smile:
I have updated the config file as per 1.6 and could start the service from the windows services interface.

:frowning:
It is important to note that running the “inodavserver start” command from the console puts back the “-Xrs” param and thus restricting the start of the service. Therefore, once the “xdav-wrapper.properties” file is updated, the service should never be started from the console.

:confused:
Still, I don’t understand why the installation points to a jdk1.3 although my java_home correctly points to my jdk1.3.1 directory.

Thanks for your help and best regards,

R

Hi,

during installation, TWS looks for an installed Java, that means a registered version. It does NOT look for JAVA_HOME. If no valid Java version is found in registry, it looks for the JRE that comes with Tamino. So if you want TWS to use java 1.3.1_01, you have to install this JDK prior installing TWS.

Best regards,
Martin

Hi Martin,

Herebelow is what my registry keys look like. JDK1.3.1 was installed prior to TWS … It still picks up the JDK1.3 …

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft]

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit]
“CurrentVersion”=“1.3”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.3]
“JavaHome”="d:\JBuilder4\jdk1.3"
“MicroVersion”="0"
“CurrentVersion”="1.3"
“UpdateVersion”=“000”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.3.1]
“JavaHome”="d:\jdk1.3.1"
“MicroVersion”=“1”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in]

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in\1.3]
“JavaHome”=“d:\JBuilder4\jdk1.3\jre”
“RuntimeLib”=“d:\JBuilder4\jdk1.3\jre\bin\classic\jvm.dll”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Plug-in\1.3.1]
“JavaHome”=“C:\Program Files\JavaSoft\JRE\1.3.1”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment]
“CurrentVersion”=“1.3”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.3]
“JavaHome”=“d:\JBuilder4\jdk1.3\jre”
“MicroVersion”="0"
“RuntimeLib”=“d:\JBuilder4\jdk1.3\jre\bin\classic\jvm.dll”
“UpdateVersion”=“000”

[HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.3.1]
“JavaHome”="C:\Program Files\JavaSoft\JRE\1.3.1"
“MicroVersion”="1"
“RuntimeLib”="C:\Program Files\JavaSoft\JRE\1.3.1\bin\hotspot\jvm.dll"


Best regards,

R

Hi R