JDBC Connection throws an error in webMethods 7.1.2 version

Hi Guys,

We are using the webMethods 7.1.2 version and database is oracle 10g express edition.

we are configuring the JDBC pools to the database and successfully working and we run the scripts against the database.

but we are configuring the database connection to the database. we got the below errors.

Error encountered [ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource acme.PurchaseOrder.dbconn:databaseConn.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection acme.PurchaseOrder.dbconn:databaseConn: after 1 attempt(s).
[ART.118.5036] Adapter Runtime (Connection): Unable to configure connection manager.
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.

we copied the classes12.jar, ojdbc14.jar, ojdbc14_g.jar to the IS/lib directory. even though we got the same error.

Please help us to resolve the issue.


Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=169869568)(ERR=12505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))

You need to copy jar/driver files to IS/lib/jars folder not IS/lib . Is that where you copied and still getting the error?

Thank you,

Hi Anil,

Thanks for reply,

i copied the files in below directories,

C:\webMethods71\IntegrationServer\lib and

Even though i got the same error.

Thanks and Regards,

dear sri,
check the driver type for oracle oci thin driver if u have gave,
then try agian,