JDBC - Connect with SSL Authentication

Product/components used and version/fix level:

Integration Server 10.3 IS_10.3_Core_Fix19

Detailed explanation of the problem:

We would like to connect our IS to a Postgres database with SSL Authentication but we’re receiving the following error:


I tried to add the SSL certificates provided by the DB Admin to via IS Admin “Security/Certificates” but still doesn’t work.

Please, how can I connect our IS to a DB using the SSL Authentication?

Thank you in advance!

Error messages / full error message screenshot / log file:

[ADA.1.204] Cannot connect to the database with DataSource class “org.postgresql.ds.PGSimpleDataSource”.
FATAL: connection requires a valid client certificate

Question related to a free trial, or to a production (customer) instance?

Production (Customer) instance

Hi Renan,

what is your JDBC Adapter version (with Fixes applied)?

I have never worked with PostgreSQL Databases with JDBC Adapter, but did you check with DBA how the listener is configured for SSL Auth?
Currently it seems only to contain properties for the transport encryption, but not for the client authentication.

You might need to enhance the “Other Properties” field with additional properties regarding the client auth certificate as the JDBC Adapter is not aware about the certificates palced in IS Admin → Security → Certificates and/or IS Admin → Security → Keystores ootb.
Please provide some screenshots of these pages for reference.


Thank you Holger for your return!

Follow the screenshots as requested (Sorry, I put the certificate only in Security → Certificates → Configure Client Certificates):

Hi Renan,

you will find the following links helpful:


@Holger_von_Thomsen , thank you for mentioning these links. I’ll take a look at it.

This subject came up again here in our team after a long time :laughing:, so I’d like to try to take advantage of this topic.

I’ve read the “Configuring Adapter for JDBC Connections” available on Configuring Adapter for JDBC Connections (softwareag.com) and I noticed the following part:

On the Connection Types screen, select the Connection Type:

*webMethods Adapter for JDBC Connection

*webMethods Adapter for JDBC SSL Connection

However, in our I.S we don’t have the “webMethods Adapter for JDBC SSL Connection” available:

Please, how can I enable the above option? Should I install a specific lib in our Integration Server?
We have the following updates for JDBC Adapters:

Thank you again in advance!

Hi Renan,

unfortunately, I never had a chance to work the JDBC Adapter 10.3 as I had to retire my webMethods-based project last year before the migration to the 10.x stream could be planned, due to various reasons.

Fixes are cumulative, therefore applying the latest should be sufficient.

You should consider opening an incident ticket with SAG support to check, why the second connection type for SSL connections is not visible for you.


1 Like

I have both SSL and the other version in both my 10.15 and 10.3 environments(both versions use JDBC adapter 10.3). I don’t remember doing anything specific to add it. Check if you skipped something during the installation and check the drivers you have.

The fixes are always cumulative, meaning if you have fix10 that means you have fixes level from 1 to 9 and 10. Using the latest fixes might solve your issue as well. Just be careful before installing fixes if you have skipped them for a very long time, so take a backup.

Thank you for your responses @engin_arlak and @Holger_von_Thomsen .
I opened a ticket with SAG support and Mr. Miro told me that this function with SSL was added in Fix #12.
We’ll try to update our DEV environment on next Monday.