JDBC Adapter Service/notification refresh


We are using JDBC adapter (JDBC_6-0-3_FP1_Fix10),wM6.5

I found it pretty strange…I am using select or any other adapter service,it was working fine(called from flow service), then i changed all “Output Field Type” to “java.lang.String” that time it worked fine, but if i run the same adapter service (called from flow service), after 1-2 days or so…it shows the same old “Output Field type” and not “java.lang.String”.
But at this point if i open my adapter service once , and then if i open flow service where that adapter service was called, then it works fine.

can not make what is possible reason, for this…always i need to open adapter service first, then open the flow service, where it is called to get things right.

Same happened with JDBC adapter notifications as well. if too many services are opened in developer window, it will not show the changed fields in notification document, only envelope doc comes.But if all services are closed, it’s absolutely okay…

I have checked developer.bat from memory …it’s 128MB

Any insight ???

Puneet Saxena

try to re-add the output parameters and in wm service, re-map the output parameters to other variables.