Java Service not working

Hi All,

I am currently trying to fix a java service in webmethods which was created 5 years ago as a part migration which we are doing here at toll. I am facing a very weird problem. The java service is using methods of classes which are packed in the jars and kept in IS/lib/jars directory. I am trying to run one line of the code at a time and it throws null pointer exception when the code tries to invoke a method in one of the java classes kept in the jar files. I am just wondering, why the code is throwing exception and unable to invoke the methods, even after the class is there in jar files. I have also tried to keep the jar files in Packages/MyPackage/code/jars but still no success.

I will appreciate quick response as I am working on a very tight deadline.

did u import the required package to the java service

Please check shared section of java service, if u are using external jars means you should import those packages to the java service.

Thanks,
Ramesh

The best place to put dependent jars is in the code/jars directory of the package.