Issues with the Creation of Database on Solaris.

Hi There,

I have installed Tamino v4141 on Solaris with the steps as listed in the documentation.
Here is the list of the Issues,

1. I was able to create the Database but could not start it. Error Message is something related to Shared Message(I am sorry I didnt’ note down the error message at this time)

2. I modified the /etc/system and included all the ‘set’ values as specified in the documentation. Restarted the system and the tried to start the database. If I remember properly, I got the same error at this time also.

3. Then, I deleted the database, and tried to create a new one(Just not to take any chances). This is the error message list from the Tamino Manager

Shared memory from previous server run detected
Creation of index space 1 (/export/home/sag/ino/db/AAB00001.1I0) has failed
System error 22 (Invalid argument) occurred
Terminated with errors

Any help in this regard is greatly helpful.

Thanks and Regards,
Ravi Chamarthy.

Hi Ravi,

I think the error about “shared memory from previous server run detected” is probably wrong. This error can occur if a previous tamino session aborted and left its shared memory segments behind. I suspect the real problem is that the kernel parameter shmmax is not large enough. The error you have is System error 22 Invalid Argument. The system call ‘shmget()’ to get a shared memory segment fails with errno 22 if there is insufficient shared memory. This can be influenced with the kernel parameter shmmax. I noticed that the documentation about the IPC parameter shmmax is wrong. When specifying the parameter there should be no commas in the number. My advice is to set the shmmax to the value of physical memory in bytes. You can find out how much memory there is on solaris with the prtconf command.

Hope this helps, Stuart

Stuart Fyffe-Collins
Software AG (UK) Ltd.

Hey! Stuart
Thanks a Lot, Got it work.
The culprits are those commas.

Thanks once again.