Issues after installing IS/MWS Patches

Hi there experts,

I installed the following patches:

TNS_7.1.2_DB_Fix9.Zip
TNS_7.1.2_Doc_Fix6.Zip
TNS_7.1.2_Fix1.Zip
TNS_7.1.2_General_Fix3.Zip
TNS_7.1.2_MWS_Fix5.Zip
TNS_7.1.2_MWS_Fix6.Zip
TNS_7.1.2_Partner_Fix6.Zip
TNS_7.1.2_WebManager_Fix3.Zip
MWS_7.1.2_CL_Fix12.Zip
IS_7.1.2_Core_Fix23.zip
IS_7.1.2_Flow_Fix7.zi
IS_7.1.2_PubSub_Fix6.zip
IS_7.1.2_SrvPrtcl_Fix18.zip
IS_7.1.2_XA_Fix3.zip

and now we cannot access the wMTNWeb anymore.I know we should be using MWS but we dont have that setup yet.
We are seeing exceptions in UAT TN on all the four servers.

Im not sure which one of the fixes/patches caused this but I’ve been told the fix -->“TNS_7.1.2_WebManager_Fix3.Zip” is supposed to help fix the below error. Ironically this error message showed up right after i installed the fixes.
Which one caused this I dont know…but I would definitely monumentally appreciate all responses from you folks to help me fix this issue…please !

FYI the JVM is 32 bit , on Soalris 10. IS is v7.1.2

http://server.company:port/WmTNWeb/index.dsp?wmtn=true

The Server could not process your request. Please make sure that you have configured ISInternal db alias in order for web manager to perform correctly.
Service wm.tnweb.configFlow:loadMenu
Error class com.wm.app.tn.err.EXMLException
0007.1039 wm.tnweb.configSvc:getUserConfig: could not get partner specific config for com.wm.app.b2b.server.ServiceException allConfig is required. com.wm.app.b2b.server.ServiceException: allConfig is required. at wm.tnweb.configSvc.getUserConfig(configSvc.java:135) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java:403) at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:631) at com.wm.app.b2b.server.util.tspace.ReservationProcessor.process(ReservationProcessor.java:40) at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44) at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:241) at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:51) at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:228) at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:30) at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:628) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:536) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:381) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:237) at com.wm.app.b2b.server.BaseService.invoke(BaseService.java:189) at com.wm.lang.flow.FlowInvoke.invoke(FlowInvoke.java:324) at com.wm.lang.flow.FlowState.invokeNode(FlowState.java:581) at com.wm.lang.flow.FlowState.step(FlowState.java:441) at com.wm.lang.flow.FlowState.invoke(FlowState.java:406) at com.wm.app.b2b.server.FlowSvcImpl.baseInvoke(FlowSvcImpl.java:1040) at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:631) at com.wm.app.b2b.server.util.tspace.ReservationProcessor.process(ReservationProcessor.java:40) at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44) at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:241) at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:51) at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:228) at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:30) at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:628) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:536) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:381) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:237) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:119) at com.wm.app.b2b.server.ns.Namespace.invoke(Namespace.java:604) at com.wm.util.template.Reporter.invoke(Reporter.java:964) at com.wm.util.template.InvokeToken.eval(InvokeToken.java:75) at com.wm.util.template.TemplateToken.evalChild(TemplateToken.java:234) at com.wm.util.template.TemplateToken.eval(TemplateToken.java:200) at com.wm.util.template.Reporter.reportNoReset(Reporter.java:1300) at com.wm.util.template.Reporter.reportToOutput(Reporter.java:1275) at com.wm.util.template.Reporter.reportIData(Reporter.java:1164) at com.wm.app.b2b.server.HTTPDocHandler._process(HTTPDocHandler.java:516) at com.wm.app.b2b.server.HTTPDocHandler.process(HTTPDocHandler.java:130) at com.wm.app.b2b.server.HTTPDispatch.handleRequest(HTTPDispatch.java:194) at com.wm.app.b2b.server.Dispatch.run(Dispatch.java:333) at com.wm.util.pool.PooledThread.run(PooledThread.java:118) at java.lang.Thread.run(Thread.java:595)

Server log exception:

“2010-09-24 12:50:39 PDT [ISS.0028.0012I] WmTNWeb: Startup service (wm.tnweb.wrapper:startupSvc)
2010-09-24 12:50:41 PDT [TNS.0002.1082I] Please configure ISInternal db alias in IS Administrator Settings → JDBC before starting WmTNWeb package, otherwise the package is not usable.”

Oh yeah…one more thing… I have made sure the ISInternal works fine…tested it and everything looks OK…

Has anyone ever seen this before?
Ive searched on Advantage / wmusers.
I couldnt find anything.

Some folks fixed it by removing tn.webmgr.60config parameter from packages/WmTN/config/properties.cnf file.

There is another post on wmusers where 3 tables went missing.

In my case tables exist and removing the parameter didnt help.

All help would be monumentally appreciated folks !

Is WmTnWeb package loaded properly? Any errors while loading?

Shahid,
No errors when TN package is loading.
Its not partially loaded.
Looks OK.

Any other suggestions? Place where I could look at?
Idea?

Thanks for coming to the rescue :slight_smile:

Did you contacted wM support for that ?
FYI, every patch campaign we did this year created lot of issues and regression. SAG have really to thing about QA on fixes :mad:

laurent,
Yes we did contact SAG support and the SR been open for more than 2 weeks now.

You are right they need to do something about this and they need to do it fast !

I think we had similare issue during our last patch campaign but I’m not able to find out exactly the opened SR (lot of SR and lot of &$&#@^& afterward).

According to my memory (so with some questions marks :p:), we did :

  • update of database/JDBC related jars (oracle drivers)
  • remove an obsolete fix that was still in the about page
  • Apply all CL fixes to all platform. I mean, if you have to apply an IS*CL* file, you have to install it also on all platforms (IS, MWS, Client, …). Idem w/ MWS ones or client ones.

That solved this kind of issues for us.

The problem with last point is … SAG groups all IS fixes in single CORE one. The principle is good, but they added also CL fixes in this bundle which is a total stupidity : according to the support (SR #5026769 ) we “have to, based on README, manually update stuffs on /common if any” :confused::confused: !!! Sure, totally NUT :rofl:

We’re complaining about bad quality of fixes for a wile and SAG promised the situation will improve with 7.1 … and unfortunately, our patching history proved the reverse :mad:

Good luck.

Laurent and our webmethods folks

This is the fix we were missing and SAG took 1 month to tell us that.

WSI_7.1.2_Cluster_Fix1.zip

After installing this and restarting our IS , our WmTNWeb came back and started working perfectly fine.

WSI_7.1.2_Cluster_Fix1.zip Fix name suggests its related to clustering. Wondering how it resolved your issue… :confused:

Here is their explanation:

The errors indicate that data is missing from one of the ISInternal tables (IS_DATASTORE), which contains the default permissions settings for TNWeb. There are subsequent errors in your logs, which indicate that TNWeb failed to retrieve/insert data into the table due to a discrepancy in the class definitions.

We believe this was brought on by the application of IS_7.1.2_Core_Fix23, which added references to a new method in our internal classes. This new method was introduced as part of WSI_7.1.2_Cluster_Fix1. Without the fix, the JVM is unable to locate this method and aborts the look-up. Subsequently, TNWeb fails to load the menu, because it wasn’t able to locate the requested data.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.