Issue while connecting from 8.2 MWS to 6.5 IS

There is a webMethods issue which we are facing while trying to connect from 8.2 MWS to 6.5 IS

We have developed a Monitoring Framework in webMethods which monitors our end to end transactions, technically as well as functionally.

Basic Architecture:
There are Framework services in the IS which logs all kinds of data (Execution Time, IS Memory Usage, Key Business Parameters of the flow, etc) for a particular flow transaction.
All this data is logged in custom Database Tables.
The data is displayed on a UI built on CAF.
There are various functions we can perform on the UI (like resubmitting transaction, graph generation, etc), in which there is an internal webservice call done from MWS to the IS service to execute the function.

The complete framework has been built on wM 8.2 but now as per our client’s request, we need to migrate and test this framework on 6.5 env also, the code (framework services as well as the IS services corresponding to the CAF pages) being in 6.5 and the UI being hosted on 8.2 MWS.

Error Recieved:
This error is received at the first web service call itself from MWS to 6.5 IS:-
[ Failed to evaluate binding expression: "#{TransactionDefaultviewView.getStatusValues.result.results}” ]
getStatusValues is the first IS service which is called when we open the UI on MWS.
We tried tracing this error and figured out that the endpoint address is not getting passed to WSDL.

IS server logs for this error:
[20]2013-02-13 18:02:05 GMT+08:00 [ISS.0053.0002C] Access denied for user SAMLart on port 8001 → ‘soap/rpc’ from

Some of the solutions which we tried:

  • Configured the same user (‘cmfuser’) with which we were logging into MWS, to the 6.5 IS also. This user was added to CentralUsers and Administrator groups.
  • The Execute ACL on the IS services have been tried with Administrators and Default Groups. Both didn’t work.
  • Edited the Extended Settings in the IS by adding “watt.server.auth.samlResolver=”
  • JDBC Pools for MWS were not configured in our 6.5 environment. So, we added a new Pool Alias pointing to the MWS database.

Functional Alias for Central Users was also not present in the IS. It was not added initially when the wM 6.5 instance was being installed.
On a hit and trial basis, we tried adding it by manually creating this file in the folder structure of the IS.
Though, we are not sure if this was the right way of doing this, but a new Funtional Alias for CentralUsers got created which was pointed to the new MWS Pool Alias.

  • This file was missing- ‘server-config.wsdd’ in the Designer package on MWS. We created the same on the server with the following content in it:
          <service name="SAML" provider="java:MSG" style="message" use="literal">
          <parameter name="allowedMethods" value="samlAssertionHandler"/>
          <parameter name="className" value="com.webmethods.portal.portlet.wm_xt_samlsecurityservice.endpoint.SamlServiceEndpoint"/>
        After this file was added, MWS was restarted.

We are still getting the same error.

Please let us know if you have any solutions/suggestions to solve this issue or if you have faced a similar situation in your earlier experience.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.