[ISC.0077.9998E] Exception --> java.lang.NullPointerException While Configuring SVN

When I am trying to Configure the SVN in Integration Server 8.2, I am getting this Error: [ISC.0077.9998E] Exception → java.lang.NullPointerException

I get this error after setting the VCS to: Subversion then I go to (Advance Settings). Once I put the Repositry URL and Clich Save Changes I get this Message (Error in subversion configuration) and in the logs I see this Error: [ISC.0077.9998E] Exception → java.lang.NullPointerException

The SVN we have is VitualSVNServer

Thanks a lot in advance

Null pointer won’t give useful info. What other error do you have?
Is that version of SVN on the official supported list?

The VisualSVN Version we use is 1.6.16.

The Exact Error I am getting is:

WMERROR a34eacf0-32c3-11e2-913f-cc66db416f92 a34eacf0-32c3-11e2-913f-cc66db416f92 182b1e3c-d638-40c4-8fd2-dddd2548b584 WM003 2012-11-20T03:37:52.502Z 2012-11-20T03:37:53.210Z
Caused by: com.webmethods.vcs.VCSException:
Caused by: java.io.IOException: Cannot run program “svn”: CreateProcess error=2, The system cannot find the file specified
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified java.io.IOException: CreateProcess error=2, The system cannot find the file specified
at java.lang.ProcessImpl.create(Native Method)
at java.lang.ProcessImpl.(ProcessImpl.java:81)
at java.lang.ProcessImpl.start(ProcessImpl.java:30)
at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
at java.lang.Runtime.exec(Runtime.java:593)
at java.lang.Runtime.exec(Runtime.java:466)
at com.webmethods.vcs.util.TimedExecutor.exec(TimedExecutor.java:53)
at com.webmethods.vcs.Command.execute(Command.java:90)
at com.webmethods.vcs.Command.exec(Command.java:187)
at com.webmethods.vcs.svn.SubversionCommand.exec(SubversionCommand.java:135)
at com.webmethods.vcs.svn.SubversionClient.makedir(SubversionClient.java:618)
at wm.server.svn.svnservices.configureSVN(svnservices.java:62)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java:439)
at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:643)
at com.wm.app.b2b.server.util.tspace.ReservationProcessor.process(ReservationProcessor.java:46)
at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44)
at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:243)
at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:51)
at com.wm.app.b2b.server.invoke.PipelineProcessor.process(PipelineProcessor.java:171)
at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:276)
at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:30)
at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:363)
at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java…wm.server.svn.svnservices:configureSVN wm.server.svn.svnservices:configureSVN

Is there something new about this issue? I have the same problem now.
@Allawatiw: were you able to fix it?

Hi

Check the documentation for storing services in VCS. There are specific version for SVN server to be used.

Kind Regards,
Lutchumaya Karri Veeranna (Kolo)

Dear graver,

No I was not able to. I had to raise a ticket to the SoftwareAG site and currently I am following up with them. You may check : if you have the user mapping done for “Itegration Server Username” user in Solution > VCS > User Mapping along with the VCS Username

Dear kolo,

I have checked the document carefully and yet was not able to solve the issue

I solved my issue by setting the path (path to svn bin folder) into environment variables.

In the Integration Server? Can you please tell me the steps you have performed?

In the Windows…
Start > right click Computer > Properties > Advanced system settings (on the left) > Environment variables… and there in System variables find “Path”. Edit it and add location of your SVN bin directory. There will be most probably some paths, so don’t delete them, just add a new one (separator is semicolon “;”)

In the Integration Server or SVN Server?

In Integration Server. Looks like that error says that the system cannot find the svn command and it looks only at the paths defined in that Environment variables Path.

And don’t forget to restart after setting that path.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.