IS61 session expire problem http clients

We are unable to use IS-6.1, as our clients get’s a “HTTP 401 - Invalid session or Session Expired” when the clients have been passive for some time and the session has expired on the IS-server. This problem unfortunately is the reason why we at the moment cannot upgrade from IS-6.0.1 SP2 to IS-6.1.

Our client’s are mainly Microsoft-ASP clients (IIS) using a xml-http-component to send HTTP and XML request’s with basic authentication. We dont have this problem in our current IS-6.0.1 SP2 environment - using the same clients.

I have studied the log-files for both 6.0.1 and 6.1 - and it seems 6.0.1 restore’s an expired session using a “Set-Cookie: ssnid=…” statement, while this dont happen in 6.1.

I have tried to look for help on the webMethods advantage site and I can see that there is an old fix for IS-6.0.1 which seems to more or less correspond to our problem. The bug is

---- IS_6-0-1_SP2_Fix114 ----

and it should solve the problem

---- Session cannot be restored after timeout period has expired when using an HTTP client. ----

I wonder whether they have forgotten to implement the same patch in IS-6.1 - even though the 6.1-release file states that this fix have also been implemented in 6.1 ?

The only solution we have found to our problem, is to change the ACL-permission from “<default> (inherited)” to “Anonymous” for our services. As this however means that there’s no authentication for our service’s, this is not a useable solution for us.

We have asked webMethod-support for a solution to our problem, but they have not yet come up with anything.

Have any of you had the same problem and do you have another solution to this problem ?

Johnny → look in your inbox
Remember that workaround is NOT supported in any way…

Hey Shyam,

I have not received your answer, so could you please send it to “johni@orange.dk”. Thank’s a lot.

Hi Shyam,

Can you share with us whatever solution you might have to solve this issue?

Regards,
Kelvin

Try belwo proeprties, may be they can help to client session timeout:

[FONT=PalatinoLinotype-Roman][SIZE=2]

watt.server.clientTimeout:Timeout period for sessions

[FONT=PalatinoLinotype-Roman][SIZE=2]

watt.server.keepAliveTimeout:[FONT=PalatinoLinotype-Roman][SIZE=2]
Length of time Integration Server maintains an
open HTTP connection to a client after returning
a response

[B][FONT=ArialNarrow-Bold][SIZE=2]

Edit Extended Settings[/b][/size][/font]. In the [FONT=ArialNarrow-Bold][SIZE=2]Extended Settings [/size][/font][FONT=PalatinoLinotype-Roman][SIZE=2]box, set the properties as follows:

[/size][/font][FONT=Wingdings-Regular][SIZE=1][COLOR=#808080]

[/color][/size][/font]watt.server.clientTimeout=[I][FONT=CourierNewPS-ItalicMT][SIZE=1]timeout period in minutes

[/i][/size][/font][FONT=PalatinoLinotype-Roman][SIZE=2]

To improve performance by reducing memory usage, set this property to a lower
value so that idle sessions are destroyed more quickly.

[/size][/font][FONT=Wingdings-Regular][SIZE=1][COLOR=#808080]

[/color][/size][/font]watt.server.keepAliveTimeout=[I][FONT=CourierNewPS-ItalicMT][SIZE=1]length of time in milliseconds

[/i][/size][/font][FONT=PalatinoLinotype-Roman][SIZE=2]

For slow connections, prevent connections from expiring prematurely by setting
this property to a higher value.
Save and restart IS.

Thanks!
KJoshi

[/size][/font][/SIZE][/FONT][/SIZE][/FONT][/SIZE][/FONT]