IS46: anyone used db insert, query or update services?

I need to use some database services in a flow but I cann’t map the right data to the $data, $criteria or $set input variables of these services.

I tried this: created a record or record list with a variable for every column in the database table I want to address and set the values of all these variables. I mapped the record or record list to for example the $data input variable of the pub.db.insert service.

This is an example of an errormessage:
“ No info available for column ‘id’ in table ‘CMN_DEPARTMENTS’”
The record that was mapped to the $data input variable contained a variable ‘id’ and a value was assigned to it.

All advise is welcome.

I would suggest checking that names of the variables in the RecordList exactly match the column names in your database table.

did you find a solution to your problem? i too am getting the same error, and i have checked to make sure the names in my record match the column names in the table.



Please let me know if someone has find the solution for this.
If yes please let me know what correction I have to make.
I checked that the all variable in a document has the name as the column name in the SQL server database table.
When I tried to provide the same data manually for the pub.db:insert, it is working fine.

Thanks In advance.