IS Logs stuck !

Hi there experts,

For some reason why IS logs have stopped!.
When i tail it ,
All i see is:

2008-08-05 13:54:53 CDT [ISS.0025.0001C] Integration Server Build 134

And then nothing.
But the server does come up and is working fine but it doesnt move.
The IS is version 7.1.1.
OS is solaris 9 on 64 bit.

Any ideas what might be causing this?
Thank you all for the support

I even replaced the from another server.
But still it doesnt make the log file move when i tail it…

any pointers?
any clues as to what might be doing this?

Check your logging level. Has someone changed it to 0? Also, I’m assuming your disk is not full, is it?

  • Percio

Percio !

Logging level is ok.
And the disk has a lot of space.

its just that i dont see the packages loading and all the managers that initialize in the beginning

please help percio !
Here is the log

2008-08-06 13:50:32 CDT [ISS.0025.0001C] Integration Server Build 134
2008-08-06 13:55:04 CDT [ISU.0000.9999C] TRANET: Starting webMethods Trading Networks
2008-08-06 13:55:07 CDT [ISS.0004.0003E] Logging JDBC diagnostics to logs/jdbc.log
2008-08-06 13:55:10 CDT [ISS.0028.0013E] Startup service exited with the following error: java.lang.NoSuchMethodError: org.apache.catalina.startup.Embedded.setCatalinaBase(Ljava/lang/String;)V
2008-08-06 13:55:15 CDT [ISS.0014.0002C] Initialization completed in 289 seconds.
2008-08-06 13:55:18 CDT [SCC.0126.9999C] Unable to add ServiceCompletionListener for Transaction Manager
2008-08-06 13:55:18 CDT [SCC.0126.9999C] Unable to add ServiceCompletionListener for Transaction Manager
2008-08-06 13:55:18 CDT [ART.0115.3214E] Adapter Runtime (Listener): Listener USAA_Life_ALURD_MQ.Listeners:MIB_Test_Listener not Found.
2008-08-06 15:03:11 CDT [ART.0114.1007E] Adapter Runtime: Error Logged. See Error log for details. Error: null

I have tried deleting all Audit data/ documentstore/ wmrepo4/xastore but still the same.
What am i missing?
please help

Not sure what could be going on. Open up a ticket with webMethods.

By the way, you’ve mentioned that you have replaced, you’ve deleted audit data, documentstore, etc, etc. It sounds like you’re shooting in the dark. Be careful. You might end up causing a bigger problem than what you already have.

  • Percio

Hi jesus,

did you get any solution for that even i do face the same problem…every thing is working fine except the server logs.It suddenly stopped one day and its not working from that day.

Did you try restart IS instance via cmd line and check it?

server.bat/sh - debug 4 - log none


i have a script file written for restarting and i always use the script file for restarting,so previously it used to work normal and all of a sudden it stopped logging

Check if the logs are written in some other files.
If you have some package thats using log4j ,there can be conflict between IS log4j and application log4j

We have the same problem with wM 6.5 32bit (1.5GB of maximum memory per instance of wM). The instance runs out of memory (you can see that in the error log) and then it recovers and continues to work just fine, but from the next day onwards, no server log file is created -the other log files are fine. As soon as I restart the instance, the log appears for that day and until it runs out of memory again. I thought I share this as it might help you with your investigation.



Our problem was with unix disk space which was 100% utilised,we have checkedit later and cleared the space and then it started working…
also we have a process which was filling the logs due to whichthe problem has come,and we have stopped the problem which was filling the logs…

So did any one ever found out the reason why logs were stopped?
I have a similar issue. It would be very helpful if someone shares the solution.


We are out of disk space due to which logging has stopped…but after we extended the disk space the problem has solved…

I believe wM does not create the log files unless there is something to write in them. I made a fresh and idle installation of wM and on midnight the new logs were not created until I created some logable events and the files showed up. I also noticed when wM runs out of memory (we had this issue few months ago), server logs are one of the last things to be given a memory thread. Error logs do appear straight away however.

NB: We are using wM version 6.5.

How about permissions on the log file? Did someone start it up as root and the logs weren’t chown back to the system user?
Where does watt.debug.logfile point to in server.cnf?

I’m not sure exactly what is captured in these files, but removing dispatch.cnf and eventcfg.bin and letting the IS recreate them at startup has solved issues with my IS installation before. Not sure if that would work here. If you try it back up the installation.


Even i encountered the same prob in 8.0 environment… but when i restart the system, the log are seen in the server logs of IS admin page.

I didn’t use the tail option however.

Thank you,