To help with some validation, I want to avoid an exception based on whether it’s a queue or channel. I could create two inputs (channel or queue name) but I would rather have a single input (channelQueue) and pass that to the method (findQueue or findChannel). I was hoping there might be a boolean check like “isQueue” or “isChannel”.
Resolved. Check the channel_mode that will determine whether it’s a channel or queue.