IS is in a loop trying to connect to MQ manager


Our IS (version 7.1.2) has an MQ adapter, and over the weekend, the q manager name has changed, when IS restarted, it is in a loop trying to connect to the old q manage, with error like below:

[ADA.600.3033] Connection to Queue Manager QM.DEV.01 could not be initialized; cc=2,rc=2058.

this is fine if I can login to IS Admin, I can’t, IS is not ready (fully started, I can’t even do a telnet server 5555). seems like the IS is in a loop trying and logging the error.

Where can I find the config file where I can manually change the q manager name and restart the IS?
Thanks in advance.


I am not sure where the connection details get stored for MQ adapter but I have another solution, if you are sure about the package name that has the MQ connection, go the file system under packages and edit the manifest.v3

make the below edit

yes to no

Get the IS completly down, go the packages and edit the manifest.v3 file and start the IS.

Then enable the package manually in IS and edit the connection parameters.

1 Like

Hi Derek,

Please stop the IS, disable the package which has MQ connection details ( follow steps specified by Mahesh ) and then start the IS. Once it is up, please cross verify connection details and do the required amendments to make sure it is pointing to correct server. Kindly let us know once you implement this.


thanks guys.

But that did not work, once I changed the enabled to no, and started the IS, in IS Admin, under Adapters, the MQ package is not even there

And looking at the server log file, I do not see that package is loaded at all.

any other thought?



BTW, which package’s manifest file did you edit? I guess you must have changed WmMQAdapter which not right.

I did try my package alone, not working, then tried WmMQAdapter, that is no good.

Not sure what is going wrong here. Can you explain the steps you have followed? Or did you fix the issue with other solution?

say I have package named myMQ, that use get and put mq messages.

  1. shutdown the IS,
  2. change the enabled under the myMQ package to no,
  3. start the IS

IS will loop/log error of unable to connect to MQ, which is defined in package WmMQAdapter

but if I do the following

  1. shutdown the IS,
  2. change the enabled under the WmMQAdapter package to no,
  3. start the IS

IS will come up just fine, but then I do not have the “WebSphere MQ Adaper” under Adapter in IS Admin.

Any other ideas?

Much appreciated.


Not sure if I was clear to you :slight_smile: Lets try this way

1> Find the package that holds your MQ connection on IS
2> Stop the IS completely
3> Go to IS/packages/ and edit the manifest.v3 file (take a backup if you require before editing)
4> Start the IS
5> Once the IS is up and fine go to your adapter page and see if that connection is visible (I am sure it will not be) then go to packages>management> enable the connection package
6> Go to adapter connections and check if that connection is visible and try to edit.

If you face issues let me know.

that is exactly what I did. The problem is, the queue manager information is in WmMQAdapter package, not in my package.



You mean your connection resides inside WmMQAdapter package provided by SAG?

I can do a screen copy, buy these are the q info on the WmMQAdapter.

I believe you create an adapter instance in WmMQAdapter, and then in your own package, you then use that connection:

MQAdapter:MQPutTradesToCFO Details
Connection Type WebSphere MQ Connection
Package Name myAdapters
Connection Properties
Queue Manager Name QM
Host Name mqprod2
TCP/IP Port 1350
Server Connection Channel MQCH.QM
User Id z8pgdgz
Dynamic Queue Prefix
Encoding 00273-Native
Send Exit Name
Send Exit Init Parms
Receive Exit Name
Receive Exit Init Parms
Security Exit Name
Security Exit Init Parms
Cache Overridden Connections true
Connection Management Properties
Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000
Startup Retry Count 1
Startup Backoff Timeout (sec) 1

Can you please share the screen shot of that particular connection. You will manage your connections in a separate package not inside WmMQ Adapter.

MQPutTradesToCFO? Is this your package?

I can’t paste the screen (remote logged in today), but yes, this is the adapter setup in WmMQAdapter package.

As far as I know, you do manage the connection info in the Admin screen, under Adpaters/MQ adapters

It is the queue manager’s anem (QM in here) that I want to change

Can you share the connection name?

of course: MQAdapter:MQPutTradesToCFO

Ok… so the package that holds the connection is MQAdapter and your connection name is MQPutTradesToCFO

Do the steps suggested on this package.

well, the screen (sort of) I showed you is from a different server, I can bring up the IS admin page on the server with the problem, If I could, i’d done change the q name already.

Thanks anyway for all of your help.

I still have one last resort: have the MQ admin put the old name back so that I can have my IS back, and change the name to the new one, and then have mq admin change the q name to the new name.



Yes… indeed that was the option I was about to suggest you at last. Give it a try :slight_smile: Good luck Derek!

Can you share the Version of the MQ-Adapter (incl. Fix-Level)?

Deriving from an earlier post in this thread by derek:

There is a (custom) package myAdapters, which contains a Connection named MQAdapter:MQPutTradesToCFO.

Except for the MinPool size (should be 0, esp. when there is a firewall involved) I cannot see anything wrong with this connection.

Make sure you have the appropriate jars in your WmMQAdapter/code/jars-Folder matching the version of the MQ-Server.
For MQ 6 and below threre are 2 or 3 jars required, but for MQ 7 there are 5 jars required.
Check AdapterRequirements Guide available from SAG.