IS is in a loop trying to connect to MQ manager

thanks, but jar files are not the issue.

The MQ adapter worked fine until our MQ admin decided to change the q manager’s name while the IS is down. So when the IS restarted, it is trying to connect to the q manager using the old name, hence mq connection error. the problem is IS kept on trying in a loop, hence I can’t get to the IS Admin screen.

My problem is to figure out where Webmethods stored this q manager name in the file system so I can manually change it, and restart the IS.

Thanks for trying.

Best regards.T
Derek

Hi Derek,

If you are in Unix family, use a simple grep on entire FS’s and find out in what files that Q manager name exist and do the required changes. Can you give a try …?

Thanks,

I am running it on unix, but due to the unix version, I have not figured out the recursive grep yet.

Anyway, problem solved, thanks to all. Our MQ admin put the old name back for a minute, and I was able to go to IS admin and then change the q name.

Regards.

Derek

Hi Derek,

After doing the changes are there any clean up activities to do to take new changes like running some service which will clear up existing one’s so that the other one’s will take new values …? Any ways its good its been resolved.

Thanks,

No, nothing at all, just a change of q name and save. that is all to it.

Regards.

Derek

Trying to grep the any values of the connection in file system will fail as they are stored in node.ndf files with special format.

Under IntegrationServer/packages//ns// you will find a file node.ndf. Inside this XML-structured file there is one element containing a base64-coded String.

If you decode this String you will get another XML-document in which you will the connection parameters.

After changing the values, recode the String and update the node.ndf accordingly.

In earlier days, this was the way how to change the AdapterConnection for AdapterServices, Notifications and Listener.
Meanwhile there a some built-in services available in WmART-Package to do this in Develope or Designer.

Regards,
Holger

I found the file, and decoded the string, unfortunately, it is in a binary format.

Thanks anyway

Regards.

Derek

Just want to inform you that even I was trying on this subject and it show the connection parameters when I decode the base64 encoded string which is present in node.ndf file.

Since your problem is resolved now. You can save this tip in-case if you face the issues again in future.

Thanks all for your participation!

Wait, my friend.

Are you saying you get an ASCII string after decoding the base64 encoded string from the node.ndf file?

How did you decode it?

Regards.

Derek

If you can attach me your node.ndf or copy past the string.

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

and I got something like (just show the part of it) this, you can see the name, but it is not in ASCII:

????c?o?m?.?w?m?.?d?a?t?a?.?I?S?M?e?m?D?a?t?a?I?m?p?l?c?o?n?n?e?c?t?i?o?n?N?o?d?e?V?e?r?s?i?o?n????a?d?a?p?t?e?r?T?y?p?e?N?a?m?e?w?m?M?Q?A?d?a?p?t?e?r?c?o?n?n?e?c?t?i?o?n?F?a?c?t?o?r?y?T?y?p?e?N?a?m?e;?c?o?m?.?w?m?.?a?d?a?p?t?e?r?.?w?m?m?q?a?d?a?p?t?e?r?.?c?o?n?n?e?c?t?i?o?n?.?w?m?M?Q?C?o?n?n?e?c?t?i?o?n?F?a?c?t?o?r?y?c?o?n?n?e?c?t?i?o?n?P?r?o?p?e?r?t?i?e?s??q?u?e?u?e?M?a?n?a?g?e?r?N?a?m?e

When I decoded your base64 string I could see some details like below:

hostname: mqdev.corp.jefco.com
port: 1461
queueName: QL.HMTSDEV.REMOTE.QUEUE

Is it correct?

yes, do you also see this: QMJEFBACHEDEV

Regards.

Derek

QMJEFBACHEDEV is your Queue Manager

yes, how did you decode?

regards.

Derek

Simple,

Copy past the base64 encoded string in the below link:

https://www.base64decode.org/

Copy the decoded string to a text pad or your own editor :lol:

But I would never suggest this method to change the connection parameters. It might not work sometimes. Just want to share it to you.

Have a good weekend :slight_smile:

strange, that is exactly what I did, but to no avail.

Well, thanks for trying, appreciated.

Regards.

Derek

Hi Derek,

looks like an Unicode conversion issue.

Therefore in Unicode every Characters has 2 Bytes (a question mark and the real character).

If displayed with the right settings this indeed look like a normal XML-document.

Regards,
Holger

Hi,

From the information provided by you, myAdapters is your package name. So, as suggested in previous posts, try to disable this package and bring up your IS.

/Naidu

Hi,

As per the details provided by you, you must disable the package myAdapters , then try to bring up your IS.
Once IS is up, enable the myAdapters package and go to MQ connections page. There you can change the queue manager name.

/Naidu