IS Deployer - Deployment Candidate not visible

Hello,
I ran into problems when automating build & deploys in the very last stage.
I don’t see Deployment Candidates in Deployer (no matter if created manually in IS Deployer or using ProjectAutomator script), nor I can deploy them using command line tool.

I created build from all packages using ABE. Repository is then mapped to directory with this build, Deployer Project can be created using this repository, packages/assests selected, map created, but when Deployment Candidate added it cannot be seen on tab Deploy. I know that candidates exist - When I go to Define tab and remove asset/package i can see all added candidates on Deploy tab. When I add anything it disappeares again.

when I try to deploy this candidate using command line tool I get error log like


Unknown system type: “null”.





and
com.wm.deployer.common.DeployerException: com.wm.deployer.common.DeployerException: java.lang.NullPointerException

Same behavior is visible on two independent IS servers with version 8.2, but only with Repository type projects (runtime ones are ok).

Version 9.8 seems to work without any problems.

Did anybody see such behavior before? Is there some settings/property that is causing this? Or is it just some bug?

WmDeployerResource version is 8.2.2.0.232
WmDeployer package version is 8.2.2.0011-0299 - DEP_8.2_SP2_Fix11

There is Fix15 Available, I’ll try to install it as well.

Furthermore when I tried to Install Resource Package to IS i get error
Failed to install Resource Package on Server ESB_IS_T1: [ISS.0086.9144] Exception occurred while checking target package name

Thank you for any ideas.
Lukas

Hi Lukas,

Is this deployer issue started happening recently and used to work before?

Any changes to your DEP environment and assuming your source and target deployment is 8.2?

Please try to install latest fix and give it a try.

HTH,
RMG

Hi Lukas,

latest Fix I know of is DEP_8.2_SP2_Fix18.

Please note its list of required Fixes:

Remember to update the ResourcePackage to the new fixed version.

Regards,
Holger

Yes that’s a valid points to be checked :smiley:

HTH,
RMG

Gentlemen, thank you for your suggestions :slight_smile:

rmg: We didn’t try deploys from repositories (we used runtime) previously, so it’s not a fresh problem…

So I installed webMethods Deployer 8.2 SP2 Fix 15 (and propagated Resources packages) on all servers
In UpdaterGUI this was the latest fix i could see. I don’t quite understand why some of the latest fixes are not visible. (Not a first time I experienced this). Please drop some comment if you have experience with that…

now the versions are:
WmDeployerResource 8.2.2.0.232
WmDeployer DEP_8.2_SP2_Fix15 8.2.2.0015-0312

On IS/Solutions/Deployer/Servers/IS&TN/test i get:
Successfully connected to Integration Server ESB_IS_T1. Deployer Resource Package reports version 8.2.2.0.312.
Integration Server reports version 8.2.2.0.228.

Deployer candidates are visible now !
Newly I face issues when I try to deploy existing Deployment project (created before fix15 installation) it fails and no deployment report is shown (only entry for checkpoint).
New deployment candidates seems to work so far. I’ll test it a bit more…

Furthermore I get many of these errors in server.log, making the work with deployer seriously slow. I think it could be some keep alive settings in deployer/servers…? (this was happening even before fix) :

2015-11-24 11:26:04 CET [ISP.0061.0003I] Established new remote connection to ESB_IS_T2 for user kocour
2015-11-24 11:26:04 CET [ISP.0061.0002I] Expired remote connection to ESB_IS_T2 for user kocour
2015-11-24 11:26:04 CET [ISP.0061.0003I] Established new remote connection to ESB_IS_T2 for user kocour
2015-11-24 11:26:04 CET [ISP.0061.0002I] Expired remote connection to ESB_IS_T2 for user kocour


Please advice if you know how to fix that…

Thank you,
Lukas

Hi Lukas,

please check the Remote Server Aliases in IS Admin.

For the case with the missing latest fixes:
As wM 8.2 is out of support, the latest Fixes might only be visible to customers having an extended maintenance agreement in place.
Another cause might be that the fix has been suspended after it was originally published to the update server.

Regards,
Holger

I checked configuration in IS/Remote Servers, played with Max Keep Alive Connections and Keep Alive Timeout (minutes) that were set to recommended values (5 & 1), setting it to 10/2 or 15/4 didn’t help at all and just by opening one deployer project I got 164 Expired remote connection entries.

(very simple project was 22 expiry log entries and quite fast to open)

I found this KB article that describes exactly my error : https://empower.softwareag.com/sl24sec/SecuredServices/KCFullTextASP/viewing/view.asp?prdfamily=Suite&KEY=113541-4821459&DSN=PIVOTAL&DST=TCD
(however I doubt it is caused by installing DEP_8.2_SP2_Fix15 as we faced this all the time)
Unfortunatelly IS_8.2_SP2_Core_Fix15 should resolve it but only core Fix 14 is available for me…

I personally don’t think that these updates are unavailable due to some policy (on IUG this year I asked about this and Updater service should not be affected by EOS at all. It is rather about Support Incidents).
It might be due to OS availability/support: I almost believe that some fixes started to be available only for Windows, while we use Redhat Linux…?

Hi Lukas,

I can see the fix DEP_8.2_SP2_Fix18 in the Empower Fix Explorer and it seems to be active and valid.

As the Deployer (and its Fixes) are OS-independent (supported on all OS, for which IS is supported), there should be no reason why it should be available for some OS, but not for others.

The Updater Service (UpdateManager) is not affected by EOS currently, as the UpdateManager 8.2.1 is still used by current wM-Versions up to wM 9.7. wM 9.8 and newer are running an UpdateManager 9.8.

But if the component for which your are looking up fixes (Deployer 8.2 SP2 in this case) is out of support, there might be an issue with fix visibility if you are not having an extended maintenance agreement for it.

Regards,
Holger

I asked our consultant about this EOS policy regarding fixes available through updater.

I found another problems with Deployer after installing DEP_8.2_SP2_Fix15 (…both visible on picture in attachment):

  1. First DeploymentSet I create within project is useless, as I cannot select any Type of assets to choose from (Packages, webMethods Files, …) Second one is ok, BUT:
  2. no TN assets can be added from our IS DEV server. Strange is, that i can select assets from Test/Prod servers, where the same DEP fix resides. Also WmDeployerResource is distributed in same version accross all environments.
    SAG claims that such issue should be resolved by DEP_8.2_SP2_Fix17 (which I don’t see in updater). I tried many things but still no change. Rolling back the fix doesn’t seem to be a good option either.
    I guess you didn’t run in similar situation, did you?

Hi Lukas,

did you try a double click on the set which seems to be useless?

In most situations I have seen such behaviour (even in 7.1.x, I am not sure with my 9.5 currently), this could be solved with a double click.

Regards,
Holger

Thanks Holger, that actually works :slight_smile:
the problem with missing TN assets is the main problem though. Now we only can export-import TN assets…

About the fixes I got clear answer:

Hi Lukas,

this is called bad luck :smiley:

About the issue with Fix visibility your quote states my assumption I have posted earlier in this thread.

May it is time to consider an upgrade to a more recent version.

Regards,
Holger

that is clear.
We’re already planning it for Q1, but till then - seems like we’ll have to survive with export-import :slight_smile:

Funny is that I can see assets on other servers with same fixes installed, I can see even these 8.2 DEV TN assets from our 9.8 IS Sandbox if I connect to it. The .dsp and .js seems to be the same on 9.8/8.2 so I guess it is a combination of number of assets and some IS package/java bug.

It could also be a strategy to offer you update fix 15 that brings in the error that can only be removed with fix 17 for which you have to purchase the support extension :twisted: - I believe that is not the case :roll:

Yes you may have to wait for your upgrade and continue with work around :frowning: :smiley:

HTH,
RMG