IS 7.1 Client Java API is not compatible with JDK 1.4

My customer is going to call the Integration Server 7.1 Client Java API form a Websphere 6 Application which is build with JDK1.4. Now we receive the following exception when calling the IS API:

java.lang.UnsupportedClassVersionError: com/wm/app/b2b/client/ServiceException (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:808)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:475)
at java.net.URLClassLoader.access$500(URLClassLoader.java:109)
at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:848)
at java.security.AccessController.doPrivileged1(Native Method)
at java.security.AccessController.doPrivileged(AccessController.java:389)
at java.net.URLClassLoader.findClass(URLClassLoader.java:371)
at java.lang.ClassLoader.loadClass(ClassLoader.java:570)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:442)
at java.lang.ClassLoader.loadClass(ClassLoader.java:502)
at at.rso.workflow.test.TestSyncTask.testSyncTask(TestSyncTask.java:48)

This exception occurs when the source is built targeting a JDK that is not supported by the JDK attempting to run it. In the above example, the wm-isclient.jar was built targeting only JDK 1.5, but the web server runs JDK 1.4

For the customer there is absolutely no way to switch from JDK1.4 to 1.5, because Websphere6 doesn’t support JDK1.5. Any ideas how to resolve this? Would it be possible to provide a client API with JDK 1.4 compatibility? From my point of view the API should be JDK 1.4 compatible, because most customers are still at 1.4.

Thomas

Did this issue get resolved or you are still waiting for reply from webmethods. I am in process of looking to upgrade to 7.1 version, hence the question. Also if possible can you send me any specifics that I need to look when upgrading to 7.1 version similar to JDK version compatability?