Incompatibility with Tomcat Versions above 4.1.18


some users realized compatibility problems with Tomcat Version above 4.1.18.

Currently X-Application 4.1.1 runs with Tomcat 4.1.18 as default.

The reason for the problem is, that Tomcat 4.1.24 and above were upgrated to Xerces 2.3.

Earlier versions (e.g. Tomcat 4.1.18) support Xerces 2.1. X-Application 4.1.1 also requires Xerces 2.1.

We would recommend you to use Tomcat 4.1.18, because this is tested and stable.

If you want to use Tomcat 4.1.24 or later, you have to change Tomcat’s Xerces version back to 2.1.

This can be done as follows:

1) rename tomcat/commons/endorsed to tomcat/commons/endorsedOrig
2) create a new tomcat/commons/endorsed directory
3) copy the files xapplication/prerequisites/lib/ext/xml-apis.jar and
xapplication/prerequisites/lib/ext/xercesImpl.jar to the new directory

That’s it. If you start one of the X-Application examples, you should see Xerces version 2.1 printed to Tomcat’s console window.

Hope that this information will help you.


Hi Mr. Raab,

Thank you so much for the message above. I was facing with this problem since May/03 (take a look at: ).

I think that it occurs mainly on WindowsXP platform.

Regards, Ito :slight_smile:
X-Application Version: 4.1.1, 3.1.3
Tamino Version : 4.1.1, 3.1
Platform : Win2k, WinXP, Solaris, Linux, …
WebContainer : Tamocat 4.1.1, Tomcat 3.3.1
JDK Version : 1.4.1, 1.3.1