Invoking service from Excel

Hi all,
I have created a simple mapping service in wM4.6. In the developer I click on my service and then click on compose from the top menu selections. I select “Generate code”, I am then given 3 choices. I select “For calling this service from a client”. I click on Next and I am given more choices. I select “Excel 97/2000”. Then basically I am asked where should I store the resulting excel sheets. I follow the rest of the instructions in creating the excel sheets. However, when I try to Invoke the service from Excel, I get an error saying that Excel is shutting down b/c of an error. I don’t know why it is doing this. Any help would be greatly appreciated. Thanks.

Piyush

Piyush, do you have any indication of what the error is? Try running the code with the Integration Server stopped. Do you get the same error message as when the server is running?

Try creating an empty Java service within your Developer environment and perform the same steps “for calling this service from a client”. Does Excel shut down even when the Java service is not doing anything?

Try turning your Integration Server debug level to 11 (the secret stop above 10). Do you see any relevant messages?

Hi Dan,

I tried all of the suggestions that you mentioned and nothing seems to be working. I think it is an Excel problem because like you said, I tried turning off webMethods and tried running the invoke service in Excel and got the same result as when webMethods is running (the result was that Excel says that there was an error and that Excel is shutting down). I am not sure what the problem is. If anyone has done an invoke from excel before any tips would be greatly appreciated. Thanks.

Piyush

It could be an Excel limitation, I know that it won’t handle anything over 64,000 lines.

Hi,

Anyone tried using Excel with Office XP Web Services Toolkit 2.0 to access Web services (via wsdl) created by WebMethods ?

I failed to invoke WebMethods web services using Excel.

Ian Kwok

Hi All,

I am getting the below error when i click on execute button, cud you help me to resolve this issue.

Error:

Automation Error
The Specified module could not be found.

I have added the reference "webMethods 6 type Library "

but still am facing the issue.

and In my machine Excel 2010 is available.

kindly help me to resolve this issue.

Thanks,
Raj

Hi All,

I am getting the below error when i click on execute button, cud you help me to resolve this issue.

Error:

Automation Error
The Specified module could not be found.

I have added the reference "webMethods 6 type Library "

but still am facing the issue.

and In my machine Excel 2010 is available.

kindly help me to resolve this issue.

Thanks,
Raj