Invalid XML character when trying to view pipeline in myWebMethods portal

I am running into a problem trying to view the pipeline of a service in the my webMethods portal. The exact error is

[POP.012.9002.wm_pipeline_edit] Remote Exception caught: electric.util.WrappedException: org.xml.sax.SAXParseException: An invalid XML character (Unicode: 0x0) was found in the element content of the document.

The information is sent to the service from the mainframe. The service then publishes the document to the broker where the subscriber writes it to the Oracle table. There are no issues with the services - they all appear to be working and the document is successfully published and the subscriber retrieves it. I can not view the pipeline anywhere through the process – either in document monitor, the publish or subscriber service.

[FONT=‘Times New Roman’]What I have tried:

  1. I have found an article on Advantage [url][/url]
    It suggested to use base64Encoding. I tried to stringToBytes then base64Encode, and it did not work. Then I tried base64Decode then base64Encode, with the same results.[/font]
    2. I have tried stringReplace to search for the invalid characters (x00 and 0x0) and replace them. That appears to work for some documents, but not all.

    Does anyone have any suggestions? I am sure I am missing something obvious. Thanks in advance.


I am also facing the same issue.
Did you get any resolution?