Internal error while comparing two strings

Hi everyone,

Did anyone of you encounter an internal error when trying to compare an arbitrary string to ‘.’? We are running wm 6.1.

You can try it yourself, simply create a small flow:

str1 = ABCDE
str2 = .

BRANCH (Evaluate labels = true)
SEQUENCE (%str1% = %str2%)

If you debug it, it will throw an ‘Internal Exception’ ([ITU.0001.0001]), if you just run it, it will throw:

‘java.lang.StringIndexOutOfBoundsException: String index out of range: 1’

The workaround is easy (i just wrote a small java string compare), but it should not be necessary!

Maybe webMethods interprets the ‘.’ as a number and internally tries to cast the string into a float?

Any ideas :confused:?

Thanks a lot for any suggestion!
Best regards,

can u post full java service ?

Hi Rama,

it’s not happening in a java service, my description above was describing the structure of a flow service.

Just create a simple flow service according to the described structure.

Best regards,

Seems like a possible bug. You probably want to open a service request with tech support. Unfortunately, the first thing they’ll probably want you to do is upgrade to a more recent version. Have you tried this on another version? I ran this on 6.5 SP2 on Win XP and had no trouble.