Integration server hangs at loading packages

Integration server hangs at loading packages


2009-08-14 17:18:38 EDT [ISS.0025.0002C] Package Manager started
2009-08-14 17:18:38 EDT [ISS.0025.0011C] Package Replicator Manager started
2009-08-14 17:18:38 EDT [ISS.0028.0001C] Loading packages

At this point integration server is stuck. Not sure why this is happening recently. I went through the logs and found there was an issue with threads earlier

2009-08-12 00:04:05 EDT [ISS.0069.0018W] No threads available to run task {1#{po
ol min=2 max=5 size=4 inUse=5 miss=29165 draw=1049213 drop=0 create=5}}(Remove E
xpired Cluster Sessions, 300.0, 1250021486880, running)

Any thoughts?

RK

Hi Ramesh,

What is the current server thread pool setting in your IS. can you try increasing the number of maximum threads under settings ----> resources.

Thanks
Deb

Ramesh,

What version of the IS is this issue happening? What is the Database that you are connecting to?

Cheers,
Akshith

Deb,

I increased the pool size from

watt.server.threadPool=256
watt.server.threadPoolMin=10

to

watt.server.threadPool=512
watt.server.threadPoolMin=20

But still didn’t help.

Akshith,

I am using wM 6.1 SP2 version. Database Oracle 10g.

Hi RK,

Please check if any of these below advantage link helps.

https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1614319656

Also try the below link. It provides info about 6.1 SP2 enhancement and fixes.

https://advantage.webmethods.com/docid536945547

Good luck
Deb

Have you tried disabling the non-webMethods packages (you can do this by modifying the manifest.v3 file under each package physical directory) and starting?

At minimum, disable the non Wm* packages. At max, disable everything but make sure you leave Default, WmPublic, and WmRoot enabled.

Once the server starts (if it does) you can selectively enable packages through the Administrator and see which one chokes.

This is an easy test to identify if a particular package or circular dependency in packages is causing a problem.

Ramesh,

Try bringing up the IS in safe mode…“server.bat -safeboot” and this will enable only the WmRoot package. In my expereince i saw this happening due to a custom package/code issue so you might want to investigate in that direction. Also, this might be of some help…

https://advantage.webmethods.com/advantage?targChanId=kb_home&oid=1614097777

Cheers,
Akshith

I don’t believe safeboot was available until version 6.5 or 7, was it? RK is on 6.1

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.