Installing and configuring XML Adapter V42

Hi there,

I have a problem with configuring the XML-Adapter. I installed Adapter tools 4.1.1 and then the XML Adapter on the machine. Then I configured the adapter along the Adapter’s User Guide:


Schema URI: //
Port number for HTTP poll: 8080
Size of thread pool for http poll: 20
Size of job queue for http poll: 100
Poll time for file poll: 10 (besides: 10 what? seconds? times per minute?)
Working dir: E:\WorkingDirXML
Completion dir: E:\CompleteDirXML


no additional entries


no additional entries

Then I tried to test it, but it hangs in the step “Start adapter process in test mode” I can let it start for hours…nothing happens.

What could be the problem?



Have you tried running in debug mode to see if there are any errors output?

The poll interval is seconds.

Unfortunately, I can’t get into debug mode. Before entering debug mode, seven steps are passed from which the last one is the one in which the process hangs up. So I never get the debug output window.


We are running the v4.2 xml adapter with the v4.6 tools, and have not had any issues. You may want to try the v4.6 patch.

 If you email me I can send it to you, I only have the Sun and NT version.  If you are running HP, you may need to contact webMethods as the v4.6 patch has errors in it if you install it in a HP environment. 


Richard is right – there is a patch. I would recommend that you download it from the Advantage Web site. Richard, you probably don’t want to be the one re-distributing that software from a licensing perspective…