Installation Error in 7.1

Hi,

I have install the webMethods 7.1 component. while confuring the Database pool in myWebMethods its showing test pass after proving the database detail.but while running the analytical,prediction error it throwing error like :

Test of Archiving Failed
[wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]Connection refused, (DESCRIPTION=(TMP=)(VSNNUM=169869568)(ERR=12516)(ERROR_STACK=(ERROR=(CODE=12516)(EMFI=4))))

and while testing again DatabasePool connection after the above error in Anyaytic Error in myWebMethods it also throw same error and while testing in JdbcPool in Integration Admin page it also throw error after error came in Analytic Engine.

Can you please guide why this oracle JDBC connection error is comming only after when i start the 3 server(Analytic,prediction,datecollector before that all JDBC connection are stable and working fine.

Regards
Reema

Hi Reema,

i’ve got the same problem after i change the “outbound Password”.

Befor i’ve changed it i had a stable webMethods installation/Configuration and the JDBC Connection to my Oracle Database are also runs perfect. But after i’ve change the outbound password the test fails with the same Error Code that you have. I solved this issue with a new JDBC Connection with the same settings from the prevoius connection. Then i’ve change the associate connection for all Functional Alias Definitions and now all test works fine.

I hope i could help you.

regards
Pawel

Hi,

webMethods 7.1 configration with oracle database i have used 10 G express edition. I am getting the error(as show below) when ever i start Analytic,prediction,datecollector server.before starting this 3 server all database connection was sucessfull. is this becouse i am using 10 G express edition.can i have to use 10 G standard edition.

Test of Archiving Failed
[wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]Connection refused, (DESCRIPTION=(TMP=)(VSNNUM=169869568)(ERR=12516)(ERROR_STACK=(ERROR=(CODE=12516)(EMFI=4))))

Please guide me on this part.

reema

Does your oracle database password contains any special characters ? I remember somewhere in a post, they have mentioned special characters in oracle db creates problem in webmethods… but i am not very sure… just checking if that is the case with u…

Hi,

my password does not contain any special characters.

Regards
Reema

I’m having the same issue. Can you someone suggest how to resolve this.

Thanks,
-rk.

sdsdsd

I have solved the issue doing the following:

In Settings > JDBC Pools, create a new Pool Alias Definitions, and change all the Pool Alias Definitions to this new Pool Alias Definitions. Restart all the Pool Alias Definitions and test them.

Hi,

I too facing the same issue…

Test of ProcessAudit Failed
[wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]Connection refused, (DESCRIPTION=(TMP=)(VSNNUM=169869568)(ERR=12516)(ERROR_STACK=(ERROR=(CODE=12516)(EMFI=4))))

Test of TN Failed
[wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]Connection refused, (DESCRIPTION=(TMP=)(VSNNUM=169869568)(ERR=12516)(ERROR_STACK=(ERROR=(CODE=12516)(EMFI=4))))

Tried by creating new alias, restarted all components…no luck…

If any other views please share the same.

Regards,
Sam

I faced the same issue, seems like connection or sessions permitted in database is too less. When IS is not able to get the connection it gives ORA 12516 although it is little confusing as description for this error says no listener found. So check if the database instance is accessible from external client utility. Is this test database (like on your machine or some real database server) ??

If its your own test database you can increase the number of sessions in **.ora files.

cheers!
nD

Hello

My really problem was that I didn´t have enough Oracle process. I solved with the following:

http://www.shutdownabort.com/errors/ORA-00020.php

I hope this can help you

Regards

Hi Team,
I have created a “Pool Alias Definitions” in IS 7.1. But upon Restart the created pool alias definition disappers. Can you please suggest the soln.
Also, The Functional Alias defn create link is not visible, because of which I cant create any Functional Alias.

Many Thanks,
Salian

Creation of functional alias option is not available on IS, its set of predefined webmethods (IS) components.

Are you getting any errors in server logs when you restarting your IS?

Hi,
Please find some of the error logs I copied from server logs:
"
2010-09-13 13:14:32 GMT+05:30 [ISS.0028.0012I] WmJDBCAdapter: Startup service (wm.adapter.wmjdbc.admin:registerAdapter)
2010-09-13 13:14:33 GMT+05:30 [ART.0114.1100I] Adapter Runtime: Facility 1 - JDBCAdapter registered with bundle com.wm.adapter.wmjdbc.JDBCAdapterResourceBundle.
2010-09-13 13:14:34 GMT+05:30 [ADA.0001.0701W] Exception while creating “SampleConnectionProperties.xml”
2010-09-13 13:14:35 GMT+05:30 [SCC.0126.0200I] SCC ConnectionManager pool Connection:conname started
2010-09-13 13:14:39 GMT+05:30 [ISS.0028.0012I] WmJDBCAdapter: Startup service (pub.pollingNotificationUtils:startup)

2010-09-13 13:14:42 GMT+05:30 [ISS.0028.0013E] Startup service exited with the following error: com.wm.app.b2b.server.ServiceException: The ISInternal functional alias is not configured properly on the JDBC Pools page. Assign a valid database pool and restart the Integration Server.


"
Does it help?

Also, the pool alias defn I created is as follows:

Driver Set up

Alias Name DataDirect Connect JDBC Oracle Driver
Alias Description : webMethods DataDirect Connect JDBC OEM driver
Driver Class Name : oracle.jdbc.pool.OracleDataSource

JDBC Connection Pool Alias

Alias Name jdbc pool
Alias Description jdbc pool test
Associated Driver Alias DataDirect Connect JDBC Oracle Driver
Database URL jdbc:wm:oracle:localhost:1521;serviceName=XE
User Id system
Password *****
Minimum Connections 0
Maximum Connections 10
Idle Timeout 600000 milliseconds

Thanks,
Sukesh S

Did you assign the pool you created to the functional alias… if yes test the connection if is able to set up communication with DB successfully… seems there its not working in ur case.

Thanks for the reply,
I can’t find the link to create functional alias. There are 2 links namely:
. Create a new Pool Alias Defination
. Create a new Driver Alias Defination

Is it something I have not included during the Installation process.

Regards,
Salian

Against every function alias, you would find “EDIT association” click there browse and look for ur JDBC pool and associate that, Restart IS after that.

Hi,
my real problem is the unavailability of “functional alias”. Can you please ellaborate how to check functional alias.
I have attached the image file(image3.zip) of my IS server for your reference.

Also, the “jdbc pool” that I have created disappears once I restart the IS server.

Thanks,
Salian
image3.zip (24.5 KB)

Hi Again…
I could see the following file inside folder C:\webMethods7\IntegrationServer\config\jdbc\function:

Archiving.xml
CentralUsers.xml
DocumentHistory.xml
ISCoreAudit.xml
ISInternal.xml
ProcessAudit.xml
ProcessEngine.xml
Reporting.xml
Staging.xml
TN.xml
Xref.xml

Is there some change I need to do to this files.

Thanks,
Salian

Thanks Devexpert,
The “Wmprt” package error is now resolved.

  1. I pointed the Functional Alias “Process Audit” link to the Pool Alias Defination created by using the jdbc url.
  2. Restarted the server.
  3. In Designer, pointed the Process Audit Database to “Use IS jdbc pool parameters”

Thanks,
salian