ino:messagetext = INOXPE8733

Hi Taminoes,

I’m mapping Adabas C via X-Node and I’m facing with the message above when I try to add new messages to Tamino.
It was working fine before add another doctype in the schema. Since then, it does not work at all.

Thank you in advance, Ito
adaxml_nXML.TSD (8.5 KB)

I tried to reproduce your problem in Tamino but I can’t. I defined your schema and stored an instance of each doctype (nXML, dado and employee) without error. I can retrieve them too. I have attached my example xml in case it helps…

Some questions:
What version of Tamino are you using?
When you get the INOXPE8733 (non numeric data in numeric field) what doctype are you storing?
Can you please attach the xml for this instance to your next post ?

Many thanks
test.xml (386 Bytes)


Attached to this is the response when I try to store your test.xml file.

My environment is:
- Tamino v4.1.4.1
- WindowsXP
- IE v5.1
- Adabas C v3.1.1.34
- Apache v1.3.22
- Entire Network v2.6.1.0

The error occurs when I am storing employee doctype.

Before append “dado” into “adaxml” it was working fine and I could insert, delete or update data in Adabas C. Maybe if I recreate the database, It could be work again. What do you think?

Thank you, Ito

Sorry but I still can’t reproduce this problem. I made my environment the same as yours (apart from XP - I use Win2K) but it still works.

As far as I can see the only element that should have numeric data is birth, and this is mapped to Adabas. If I try to store non-numeric values I get Adabas response 52 as expected.

Are you sure the schema you attached is the one you are using? Could you please try to undefine your existing schema (if you don’t mind losing your Tamino data) and redefine it using the schema you attached.

Many thanks

Hi Bill,

I undefine it in many ways (using my attached file in the previous message, removing birth, creating a new db, etc) and it still doesn’t work.

I suspect that Tamino does not work fine under WindowsXP, because recently I was trying to use X-Application (see my messages in this forum) and it doesn’t work as well. :frowning:

I will use Tamino and Adabas C as is, but I really appreciate if you pay attention about errors evolving WindowsXP and Tamino, ok?!

Thanks a lot Bill,


Still can’t reproduce problem on XP. I tried the following environment:

  • WinXP Professional
  • Tamino
  • Adabas V322/PL27 (no need for Entire Net-Work or Proxy Server)
  • Microsoft IIS on port 1080
  • Apache 1.3.24 on port 80

The schema loads fine, and the test documents work too, via both IIS and Apache. I can retrieve employees using Tamino Interactive interface or via Natural to Adabas directly. Sorry this doesn’t really help you. If anyone has any other ideas please let me know. Cheers.

[This message was edited by Bill Leeney on 16 Jul 2003 at 11:39.]

Thank you so much, Bill.

You can retrieve, insert, delete and update data into Adabas C, right? I can just retrieve…

Well, acording to this, I can presume 2 things:
1. Something could be wrong with my WinXP
2. I have to upgrade my Adabas C to v3.2.2.27

The first one I would like to discard, because if it is true, I’ll have to reinstall it. :frowning:

The second, is better. I have heard that there is Adabas C v3.3 available here in Brazil, so I will upgrade to this release and test my Tamino again. :cool:

Cheers, Ito

Yes I can retrieve, insert, delete and update data into Adabas C. I don’t think an Adabas update will help because you aren’t getting an Adabas error - the error comes from Tamino. Do you have any server extensions installed?
If not, I guess an Adabas update is worth a try…good luck.

Hi Bill,

I reproduced the error in a Win2k installation using ino411 and ada331. Firstly, we could insert the “James Bond” sample into ada_empl doctype but, when we delete all content from Adabas (via DBA Workbench), the error appeared (8733).

In my opinion, after mapping adabas C, we cannot change the content using another application. (e. g. DBA Workbench, Natural, etc), because it will cause some problems into Tamino.

Thanks in advance, Ito

Hi Bill,

I can’t say that the problem is solved, but I could back to insert, update and delete data after restoring EMPLOYEES to its original content into Adabas C. :wink:

Thank you, Ito