Impossible to load csv file in Integration server

Hi,

I work currently with WebMethods 9.0 but I want load one csv file in order to execute my flow service then the following message “Unable to parse input file” not allows to load this last.

Could you help me to solve this defect.

Thanks.
New Microsoft Word Document.docx (227 KB)

As per the screenshot provided you are trying to load the CSV file while running the serivice at that time it only loads pipeline files which are in XML(IDataXML) format.

In order to load a CSV file and parse it you need to use the below things in your flow service

pub.file:getFile
pub.flatFile:convertToValues

and a flat file schema to parse the CSV file.

Thanks for your time.

I have used this library “pub.flatFile:convertToValues” but the same problem occured.
Could you give me any details please regarding use of the two library (pub.file:getFile, pub.flatFile:convertToValues) with a flat file schema in order to parse csv file? Because I am novice on WebMethods technology

Thanks for your help.

Hi,

I have implemented the service following your remarks then whether I execute the flow servivce the message below appears :

Launch started: 2013-09-25 10:28:09.206
Configuration name: secBusException (1)
Configuration location: C:/Users/b.mfouka.mokono/workspace90/.metadata/.plugins/org.eclipse.debug.core/.launches/secBusException (1).launch

Could not run ‘secBusException’
com.wm.app.b2b.server.ServiceException: [FFP.0018.0009] Input parameter ffData cannot be null.

com.wm.app.b2b.server.ServiceException: [FFP.0018.0009] Input parameter ffData cannot be null.
at pub.flatFileImpl.convertToValues(flatFileImpl.java:139)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

Input parameter ffData is null, why?

Thanks!
Doc1.docx (226 KB)

You need to use getFile service and get the file data in stream
after that map that stream to ffData in convertToValues.

For creating the flat file schema you need to refer

Flat_File_Schema_Developers_Guide.pdf from SAG documentation.

Hi,

Thanks for your help.

I solved the defect through moving csv file in the same plateform which the server because I worked before
with this file in local but I use webMethods Designer via remote server.

Regards