HTTPS to TN via RI

Hi All,

We had problems today with partner not being to connect to our server,
The error received by the partner were
HTTP.ResponseText = ‘

Access Denied

HTTP.Status: ‘401’
HTTP.StatusText: ‘ [ISS.0084.9004] Access Denied’
We double checked the certificate set up and found it to be as required.
Then we installed the partners certificates in our browser tried to connect
https://server:port/WmTNWeb and we were able to see the home page for the partner.
But when partner tried to do the same he was prompted for login prompt. Suprisingly the partner also did not even receive a certificate selection dialouge.
The partner then added our server IP to trusted sites in IE. Then he was able to connect to our servers. Then the partner removed the setting and he was still able to connect to our servers.
What I fail to understand why did the partner recieve access denied errors even when we were able to reach the servers using the same set of certificates ?
Could this anyways be related to JVM caching IP address (networkaddress.cache.ttl) ?( As we did a restart of RI servers as we had change to increase memory which needed a reboot)
Though we have solved the problem I am still not able to find the cause for the same.

Any help will be very much appreciated.