http post to Outbound URL is throwing Error Message as Bad Request 400 Error

Hello All,

Recently, we are currently upgrading our Integration Servers from webMethods 7.1.2 to 9.5.

As part of our testing, we observed that while doing a http post (from webM9.5) to Outbound URL, we are receiving response as 400 Bad Request but the same is working fine without any issue in webM7.1). We are getting this error intermettiently and not continuously.

After verifying patch fixes for webMethods 7.1.2, we found that PIE-19512 (IS_7.1.2_Core_Fix37) is available where the above error is resolved. As far as the fix, it mainly resolved the issue with combined length of username and password in the http request which is more thatn 56 characters. In our case, we are not using any user name and password while doing http post.

Regarding patches wise, we have latest patch fix installed on webM9.5, but still the issue is not resolved. Any pointers for resolving this issue will be of great help for us.

Many Thanks
Suresh Kumar

based on what you are explaining, check if you have any proxy/network level system between your system and the server that may be contributing. Do some network trace if possible.
Also, you’d better open a ticket with SAG.

Check how request are routed to your main servers. It should be proxy/dmz where request is dropped off/corupted/not routed properly

Good idea is to open ticket with SAG

Thanks Guys for the response, FYI After trying with few extended settings, we have opened ticket with SAG and working with them.

Below are the few things, which we tried to resolve the current issue

  1. Repeat the outbound http call and making use of properties available for http call and repeat step as in timeout, repeat interval. here we are verifiying with the status of http call and then repeating.
  2. Though we have already tried with this option, but as per advise given my SAG, updated the extended setting value to 0 instead of 5 (default value). With this setting, IS will always create a new connection.

Currently, we are testing the changes, will keep updating once, if we are able to resolve the issue permanently.

But i think you should still have 400 error issue, you are using reapt step for retry on error

Have tried to contact url provider system team for issue reloution. What is the response from them?