How to run or start MWS first time

Hi Folks
I have recently installed webMethods integration 10.11 free trial and configured it to use external RDBM (SQL Server).

After 10.11 installation, I ran DCC to create required schemas in db for all products including MywebMethodsServer as shown below:

image

When I go to ControlPanel->Services, I can see SAG My webMethods is installed as windows service also as shown below:

However I am unable to start MWS. Actually I am in process of learning & exploring webMethods suite and don’t know much about it.

For example, I don’t know how to start & access MWS? I know we can access it via webpage @ port 8585 but before that we need to start it and I am not sure what are steps to start it?

Also do I need to explicitly create a new instance of MWS before starting it or is there any default instance already available than I can utalize?

Can someone please comment what are the initial configurations/settings (if any) that I need to perform before starting MWS for first time?

If possible let me know high level steps (in sequence) that I should perform to start MWS first time.

Thanks

Hi Mubarik,

as shown in the screenshot the service is registered for an instance named default.
Service can be started and stoppped via Service Manager (see screenshot) by right clicking on the service and choose proper action.

Usually there is no configuration required prior starting the instance for the first time except for creating the DB schema (already done according to your description).

Starting for the first time takes a little bit longer than later starts as the instance is initializing itself.
You can check the _full_.log of the instance for progress of initialization.

Regards,
Holger

Hi Holger
Thanks for your response.

I can start service from service manager and service status changes to “Started” as shown below:

However, after that when I try to connect MWS at port 8585 then it doesn’t get connected as shown:

IS gets connected @ localhost:5555 but MWS is not connecting @ 8585. I assume that’s because it didn’t start successfully.

You advised to check full.log file but it is not getting updated at all. This log file got updated last on Sep 29th (when I installed free trial 10.11)

I tried to run startup.bat file in folder: “SoftwareAG\MWS\server\default\bin” but that batch file is also not starting server successfully. Rather it ends with following warning/error messages:

I don’t see any message or confirmation that MWS started successfully and also its not accessable @ port 8585.

Not sure if I am missing or overlooking something while starting MWS

Following are three tables in my database having prefix “MWS”:

image

Any idea what is the error in above screeshot or how can I run MWS successfully?

Hi Mubarik,

in this case please check the log files under profiles/MWS_default/logs in your installation directory if there are any messages indicating why MWS is not starting.

The startupmws.bat file is not intended to start MWS directly when configured to be used as a Windows Service.
This one will only work running as an Application.
When running as a service the bat file is only used to update the service definition in the registry.

Most MWS-related tables in database schema start with “TBL”, CommonConfigService (for Optimize environments) start with “CCS_” and the TaskEngine related tables start with “T_”.

Regards,
Holger

Hi Holger & Community folks

I was able to fix this issue but after lots of experiments.

I tried to take help of various logs including the ones you mentioned but there were multiple java exceptions coming from various modules/function call etc in logs file and hence it was really difficult to track down exact error. I couldn’t get much help/solution on web related to the errors I was seeing in log files.

So in order to fix this issue, I decided to perform different experiments (because there was room for experiments as it was new installation (means there was no chance of any critical data loss) and secondly it was dev/local installation)

Although I have fixed this issue and my default MWS is starting & connecting fine now but I am not 100% sure how exactly I fixed this issue and that is probably because I made multiple/different attempts to fix this issue. Anyways, I can at least list down steps here that I performed (and the sequence in which I performed them), that led to final resolution of this issue:

  1. Ran DCC (database component configurator) UI to recreate MWS product related tables/schemas
  2. Restarted DB server & IS
  3. Tried to start MWS default instance (using mws -s default run command)- [MWS didn’t start and reported multiple java exceptions]
  4. Created new instance of MWS and restarted DB server & IS after successful creation of new instance
  5. Tried to initialize/run newly created instance - [New MWS instance didn’t start and reported multiple java exceptions]
  6. Ran DCC UI again to recreate MWS product related tables/schemas
  7. Restarted DB server & IS
  8. Tried to start MWS default instance again (using mws -s default run command) and default instance started successfully this time

Above mentioned steps, performed in the mentioned sequence, helped me successfully start MWS finally