How to get started with API Gateway on Amazon EKS?

I’m trying to deploy API Gateway on Amazon EKS.
I created Kubernetes Cluster v1.12 and deployed the API Gateway Docker Image v10.4 from DockerHub.
I can login to the the IS with default credentials but unable to get into the API Gateway app (The username/password you entered is invalid).
In IS I can see that the package WmAPIGateway is loaded partially and in the logs there are some errors indicating that the Elasticsearch failed to start.
Also there is the following errors in the log:

  • Access Denied. Authentication resolved to user “GatewayInternalTechnicalUser”. User is not defined in any of the available user stores.
  • Access denied for user GatewayInternalTechnicalUser on port 5555 -> ‘invoke/apigateway.ui:getSolutionDetails’ from 127.0.0.1

In the official installation guide there is the following mandatory setting “sysctl -w vm.max_map_count=262144” which should help to fix this issue but this command is not applicable for the Amazon EKS.

Could you please advise how I should configure EKS cluster to be able to deploy and run the API Gateway?
I’d be very appreciate if somebody provide step-by-step instruction how to get it working on EKS.

Thanks.

The issue was solved by adding the command “sysctl -w vm.max_map_count=262144” into the Amazon EKS cluster template under the following section: NodeLaunchConfig > UserData, at the end of the bash script.