How to add an asset discovery in MWS? [SOLVED]


I am trying to configure an Integration server asset in Applications >Administrtion >Analytics >Infrastructure Components >Discovery, but when I am trying to add one the Data Collector dropdown from the dialog box is always empty and this a mandatory field.

Which step(s) I am missing to be able to have that Data Collector dropdown filled?


You need to install and configure Optimize for Infrastructure.

After doing so you should be able to select the (Infrastructure) DataCollector in the asset discovery.

Could I have deployed an Optimize for Process and Optime for Process in a same enviroment configured in MWS Applications >Administration >System Wide >Enviroments >Define Enviroments or should those be deployed separately when using same Analityc Engine, Broker and MWS.

I tryied to do it both ways but got a error message while deploying

The service is up and running and is in the same host, I do not get why is not being deployed.

Any clues, suggestions are very welcome :slight_smile:

Deriving from your error message you are hitting a port issue, the port(s) selected for the InfrastructureDC are already used and therefor the Environment deployment cannot connect to this instance.

Some more hints when configuring such a combined “Optimize for Process & Optimize for Infrastructure” Environment:

All Engines need to be configured in one single environment when there is only one Analytic Engine and Broker available.

Just add servers for template “Optimize for Process” and “Optimize for Infrastructure”.

Remember to assign the Analytic Engine to the IS to be monitored under “System Settings” in MWS, otherwise the Discovery will not work.

Make sure that the latest Fixes are applied:

  • IS 8.2.2 Fix12
  • Optimize 8.2.1 Fix10 (Fix11 [if available] seems to be unstable)
  • MWS 8.2.1 Fix15
  • Broker 8.2.3 Fix6
  • required Fixes for the above

Each IS needs its own “Optimize for Process” and Broker (the Brokers can be collected in one BrokerServer), but one single “Optimize for Infrastructure” can handle several IntegrationServers.

1 Like

Hello Douglas,
Can you please share, how was your issue resolved?

We are encountering the exact same exception, i.e during Environment Deploy, the InfraDC Component Deploy fails with the exact stack trace as of yours.

Also, there is no port conflict we confirmed with network group. Also, only when, InfraDC is online, the netstat -na shows the corresponding InfraDC port 6666, listening as below:

TCP [::]:6666 [::]:0 LISTENING

So everything seems active from backend, but still getting the error as below:

Error deploying logical server type “Infrastructure Data Collector v9.5.0.0” version “” to host “actual_host_name*”
Deployment Error: electric.util.WrappedException: java.rmi.RemoteException: Permission denied: connect; nested exception is: Permission denied: connect

Appreciate your inputs.


I installed the latest fixes as suggested by Holger and that fixed my issue.