How Do I get a Newline at the end of my record

I have created a flat file schema for my header record and it is a fixed field record. I have specified that the record length is 56 (record length) and the ‘Field or Composite’ is set to ‘NewLine’. When I run it does not generate a newline. What else do I need to do? I also specified ‘Record Identifier’ starts in position 56. What am I missing?


Is your field delimiter is Newline and what about record delimiter?

Also try to use Delmiter flatfile and set record parser newline and test the schema…

Are you doing inbound or outbound flatfile development?



I agree with RMG you define your schema with delimeter type and then specify the record delimeter as new line and no field delimeter since it is fixed length. If you go for fixed length option the flatfile will be like continious test and this schema considers that from 57 position as a new record and takes 57 to 112 as second record (here there will be no new line)

I think i am right RMG?

Define a delimted flat file schema and in each field set the field positions.


Hope it worked as i said…Any troubleshootings?