Help needed with SFTP in openssh package

Hi all,
Did anybody ever used SFTP service. I need help regarding installing the keys on local host and remote host. I followed the procedure given webmethods advantage technical notes. But still couldnt implement it. I am getting this error as shown here:

debug1: Reading configuration data packages/OpenSSH/config/options.properties
debug1: Applying options for *
debug1: Connecting to xxxxx [xxxxxxxx] port xx.
debug1: Connection established.
debug1: identity file openssh/intserv.rsa type 1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.7.1p2-pwexp26
debug1: match: OpenSSH_3.7.1p2-pwexp26 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1p2-pwexp26
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 zlib
debug1: kex: client->server aes128-cbc hmac-md5 zlib
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host ‘plslc022’ is known and matches the RSA host key.
debug1: Found key in /home/webmthhr/.ssh/known_hosts:4
debug1: ssh_rsa_verify: signature correct
debug1: Enabling compression at level 6.
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: openssh/intserv.rsa
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: No more authentication methods to try.
Permission denied (publickey,password,keyboard-interactive).
debug1: Calling cleanup 0x40015a3a(0x0)
debug1: compress outgoing: raw data 265, compressed 225, factor 0.85
debug1: compress incoming: raw data 107, compressed 70, factor 0.65
Connection closed

my question is this related to permission issues on the host or do we need to change any default settings in options.properties in the package. If anyone faced this problem let me know the solution.

Thanks.
sri

Hi Srinivas,

Are you able to slove this problem? I am getting exactly the same error. Can you please let me know the steps you have taken to solve this problem.

Thank you in advance,
Priyatham Porika

I am able to connect to the remote server. see the following:

ssh -v webmethods@xxx.xxx.xxx.xxx
OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to xxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file /homes/webmeth/.ssh/identity type -1
debug1: identity file /homes/webmeth/.ssh/id_rsa type -1
debug1: identity file /homes/webmeth/.ssh/id_dsa type -1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.1p1
debug1: match: OpenSSH_3.1p1 pat OpenSSH_2.,OpenSSH_3.0,OpenSSH_3.1*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host ‘xxx.xxx.xxx.xxx’ is known and matches the RSA host key.
debug1: Found key in /homes/webmeth/.ssh/known_hosts:14
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /homes/webmeth/.ssh/identity
debug1: Trying private key: /homes/webmeth/.ssh/id_rsa
debug1: Trying private key: /homes/webmeth/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: password
webmethods@xxx.xxx.xxx.xxx’s password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
Last login: Wed Apr 12 10:01:56 2006 from yyy.yy.yyy.yyy

when I run the command I get the following error:

ssh -vF packages/OpenSSH/config/options.properties xxx.xxx.xxx.xxx
OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data packages/OpenSSH/config/options.properties
debug1: Applying options for *
debug1: Connecting to xxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx] port 22.
debug1: Connection established.
debug1: identity file openssh/intserv.rsa type 1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.1p1
debug1: match: OpenSSH_3.1p1 pat OpenSSH_2.,OpenSSH_3.0,OpenSSH_3.1*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 zlib
debug1: kex: client->server aes128-cbc hmac-md5 zlib
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host ‘xxx.xxx.xxx.xxx’ is known and matches the RSA host key.
debug1: Found key in /homes/webmeth/.ssh/known_hosts:14
debug1: ssh_rsa_verify: signature correct
debug1: Enabling compression at level 6.
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: openssh/intserv.rsa
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: No more authentication methods to try.
Permission denied (publickey,password,keyboard-interactive).
debug1: Calling cleanup 0x10003b7d8(0x0)
debug1: compress outgoing: raw data 263, compressed 224, factor 0.85
debug1: compress incoming: raw data 107, compressed 70, factor 0.65

I copied the files intserv.rsa.pub to authorized_keys on the remote server. I just followed the OpenSSH Security Technical Note:

Thank you in advance.
Priyatham Porika

Hi ,
Any success on this one…I am facing the same issue…Please let me know how you were able to solve it…

Thanks