Getting versioning error while running the custom cockpit

Detailed explanation of the problem:

I have been using a custom cockpit application with the version 1015.0.363. while I start the server in my local machine I am getting below error in the browser’s console.

What would be compatible version of API if I use 1015.0.363 in UI ?
What would be compatible version of UI if I use 1015.0.249 in API ?

will it be any issue if I use different versions ?

Error messages / full error message screenshot / log file:

Question related to a free trial, or to a production (customer) instance?

Cumulocity Production


Your UI version needs to be less or equal the Backend API version - otherwise you run into risk that the UI tries to use API calls that are not supported by Backend yet. Backend API is backwards compatible, so a lower UI than Backend version should be fine.

1 Like

Okay !
will it be any major change between this two versions in UI ?
1015.0.249 to 1015.0.363


You can check the changes in the 10.15 Release Notes.

Hi Mohan,

in general you should be just fine using a newer fix version compared to the backend version as of 10.15 and 10.16.
I guess we even adapted the behavior for showing this message in newer versions (so that it only complains if the major or minor versions are different).

Note that in upcoming versions (10.17+) it might also be the case that the backend and UI versions are by default no longer matching.


Understood so even If degrade the UI version to backend in future if backed version is updated still will get that message right ?

So what would be your suggestion here Tristan ?

Shall I continue with same UI 1015.0.363 and Backend 1015.0.249 versions ?


So a lower UI version compared to the backend version is supported and should not lead to this message.
What you should avoid is using a newer major/minor version of the UI with an older backend (e.g. 1016 of the UI with 1015 of the backend). This could lead to issues as the UI might try to use APIs that were just introduced with the newer backend version…

As a fix for a version should not introduce a newer API, you should be just fine combining UI 1015.0.363 and Backend 1015.0.249 versions and can ignore the log entry in your browsers console.

1 Like

Thanks Tristan


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.