Getting error during WM8 start up


Hi
I am getting the following error to start the WM8. Need help your you…

[SIZE=2]----------------------------
Aug 2, 2012 5:03:58 PM com.webmethods.sc.config.ConfigurationLogger log
INFO: Out-of-band file changes will be monitored every ‘60000’ milliseconds
Should have positive integer specified for com.webmethods.sc.mws.db.cleanup.peri
od. The current value is null
Should have positive integer specified for com.webmethods.sc.mws.db.max.waittime
. The current value is null
Initializing component: com.webmethods.rtl.util.FileUtil
Initializing component: com.webmethods.rtl.util.SystemPaths
Initializing component: com.webmethods.rtl.util.Debug
Started sending JDK log messages to Log4JStarted Synchronous Event DeliveryUsing
Axis2 temporary directory: C:\DOCUME~1\376133\LOCALS~1\Temp_axis2f6304568-94a5
-4b4c-90d1-d3ab832140e5
Deploying module: addressing-1.41 - file:/C:/SoftwareAG/I
ntegrationServer/./config/wss/modules/addressing-1.41.mar
Deploying module: Autho
rizationModule - file:/C:/SoftwareAG/IntegrationServer/./config/wss/modules/Auth
orizationModule.mar
Deploying module: script-1.41 - file:/C:/SoftwareAG/Integrati
onServer/./config/wss/modules/axis2-scripting-1.41.mar
Deploying module: Mercury-
0.91 - file:/C:/SoftwareAG/IntegrationServer/./config/wss/modules/mercury-mar-0.
91.mar
Deploying module: metadataExchange-1.41 - file:/C:/SoftwareAG/IntegrationS
erver/./config/wss/modules/mex-1.41.mar
Deploying module: rahas-1.4 - file:/C:/So
ftwareAG/IntegrationServer/./config/wss/modules/rahas-1.4.mar
Deploying module: r
ampart-1.4 - file:/C:/SoftwareAG/IntegrationServer/./config/wss/modules/rampart-
1.4.mar
Deploying module: sandesha2-1.3 - file:/C:/SoftwareAG/IntegrationServer/.
/config/wss/modules/sandesha2-1.3.mar
Deploying module: soapmonitor-1.41 - file:/
C:/SoftwareAG/IntegrationServer/./config/wss/modules/soapmonitor-1.41.marCould n
ot load module policies. Using default values.
Deploying Web service: EchoWS.aar

  • file:/C:/SoftwareAG/IntegrationServer/./config/wss/services/EchoWS.aar
    Starting tomcat server
    Starting Servlet Engine: Apache Tomcat/5.0Tomcat XML validation is
    disabled
    Create Host deployer for direct deployment ( non-jmx )
    Processing Context configuration file URL file:C:\SoftwareAG\IntegrationServer\web\conf\WmTomcat
    \localhost\web#WmTomcat.xml
    Installing web application from URL file:C:\SoftwareA
    G\IntegrationServer\packages\WmTomcat\web
    com.wm.app.b2b.server.ServiceException:
    at wm.administrator.repo.getKeys(repo.java:95)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
    [/size]

Any body did face same error , then please help me…

try to start IS in safe boot mode (- safeboot) and disable wM tomcat package, till you identify the issue with that package

Hi

I replace the wM tomcat package first. Then the abouve error resolved and new error mesage encountered i.e

Tomcat XML validation is disabledCreate Host deployer for direct deployment ( no
n-jmx ) Processing Context configuration file URL file:C:\SoftwareAG\Integration
Server\web\conf\WmTomcat\localhost\web#WmTomcat.xmlInstalling web application fr
om URL file:C:\SoftwareAG\IntegrationServer\packages\WmTomcat\webProcessing Cont
ext configuration file URL file:C:\SoftwareAG\IntegrationServer\web\conf\WmTomca
t\localhost\web#WmTomcat_wm8.xmlInstalling web application from URL file:C:\Soft
wareAG\IntegrationServer\packages\WmTomcat_wm8\webjava.sql.SQLSyntaxErrorExcepti
on: [wm-cjdbc40-0034][Oracle JDBC Driver][Oracle]ORA-00942: table or view does n
ot exist
at com.wm.dd.jdbc.oraclebase.BaseExceptions40.createAppropriateSQLExcept
ionInstance(Unknown Source)
at com.wm.dd.jdbc.oraclebase.BaseExceptions40.createSQLException(Unknown


I create new user, tables using DB configurator.
[Screen shot attached: [ATTACH=CONFIG]873[/ATTACH]]

[SIZE=2]I also chenge the SoftwareAG\IntegrationServer\config\jdbc\pool\GEPGS_WM8_BaseDB.xml file, open this file in wordpad and mentioned the user and pwd in

<value name="userid">wmpgs</value>

<byte name="pswd">******</byte>

and then save it.

Then I run again the IS>bin>server.bat command

and the IS now running fine.
[/SIZE]

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.