getLastError full stack trace


If I have something like this :

--- INVOKE myPkg:flow1
--- INVOKE pub.flow:getLastError

And the myPkg:Flow1 :

- INVOKE pub.math:divideInt(num1 = 1, num2 = 0)

In getLastError my document error have only one line in callStack document list (I see only pub.math:divideInt).
Does exist a way to obtain the complete stacketrace ? In my case not just on record with pub.math:divideInt but another one with myPkg:flow1

Hi Vital,

Sorry,I am not getting you but What else do you expect to see in the getLastError output under doc error/pipeline?


Hello Vital,
the exception happened just in second level of service… hence u see only 1 service in callStack.
if the exception happened in say 4th or 5th level down… then u will see the complete stack of flow steps and details


Check the attached screen shot, is this how you need the getLastError output to look like?

OK rmg and Mahesh K. Sreenivas

I know what u mean.
You said to me to do a getLastError in flow each time I encountered an exception and put in in Pipeline.
It’s smart but I would prefere to not make the code with more statement in child services.
I would prefer to view the complete stack trace only in service I call getLastError.


I made two services:

  • temp.gerardo_lisboa.experiments.lastError:main_service
  • temp.gerardo_lisboa.experiments.lastError:aux_service

where the aux_service is just a call to pub.math:divideInts

And as a result of calling with parameters (1;0), I get an informative lastError.

I am using 10.1.
What is your version?

Best regards and Keep Safe.
2020-03-25 08_56_25-workspace101 - Service Development - uxos155c.ores.net_51310@__TEMP_GerardoLisbo.png

Hi Gerardo Lisboa
Thanks and keep safe you too.

You use wM 10.1. I know the latest versions of wM use a better way for try/catch management.
So, in your flow service you seems, to not use it but maybe the software is better for the stackTrace in getLastError service.

I use wM 9.10 version. I do exactly the same thing than you.

Or maybe it exists a watt to be more accurate.


Hi Gerardo Lisboa

As we are migrationg our wM 9.10 version to wM 10.5, I installed a designer 10.5 on my local desktop and I tried again the same kind of flow service. And I see that with the same behaviour, in error structure, I have only single flow server in my callStack document List. So if you have not the same behaviour, something is missing in my configuration.


I are using transformers.
I used an invoke.

That makes all the difference.
Try it my way.

Best regards,

Yes I thought the same things than you. I tried with a invoke insteaf of transformer and I have the exactly same result

I find the problem : it was because I was in debug.
In run mode, I have the call stack


That makes sense.

Unfortunately, debug mode in the IS not at all transparent… :frowning:

Best regards,