FTP get and remote filepath

Hello,
I am trying to do write a service that will get file from a path under the integration server (specifically from the directory IntegrationServer/FlatFiles/). I have tried several ways of specifying the remotefile path, I always get the No such file or Directory error. I am wondering if webMethods is using any virtual path. If so where is its root? and how do I specify the path to my directory in the remote file parameter?
thanks,
SK

Should Specify whole path location of c:/webmethods/server4/yourdirectory/filename

Are you doing this?

HTH.

Yes, I did that - the path actually is d:\webmethods\IntegrationServer\FlatFiles\flatfile.txt on the server

-SK

Keep in mind that the dir path is “seen” from the perspective of the machine where webMethods is installed so…

You can use the relative path such as “FlatFiles\flatfile.txt” (ie. relative to the root install directory) OR

You use the drive letter as seen by webmethods on the box where it resides. For example, if you mapped a network drive as d:\webmethods on your computer it may not actually be mapped to d:\ on the actual server. You may be having Windows network visibility type issues.

You might use an FTP client (e.g. FTPExplorer or CuteFTP) to connect to the IS box and see what the available paths are. There are two dirs in the root: admin and ns. I don’t believe there is any way to add to this list.

The admin dir is the install root. The ns dir is a (virtual) collection of the ns dir found under all the packages.

Absolute paths containing drive letters or directories outside of the IS tree will not work.

When I use WS_FTP, I do see the two directories as you said “admin” and “ns” and I figured admin refers to the root directory (IntegrationServer). Thats why I wanted to test it by creating a directory under it (IntegrationServer/FlatFiles) and having my file in this directory.
I used the value “\FlatFiles\flatfile.txt” as the remotefile parameter … Still says No such File or Directory.

I checked the NT folder permission… The directory is available to everybody.

Thanks,
SK

Thanks Folks! Its working now… I had to add
“/admin” to the dirpath.

Thanks again!!
SK
***********************End of Topic ***************

HI Nsk and reamon,

I also have been trying for the solution for this problem since many days that i had , finally i am resolved from your discussion thread…I greatly appreciate it…

Thank You
Suresh