Fresh installation of IS not starting due to incorrect classpath


I just have installed 5 new IntegrationServers 9.5 on Solaris 11.
These are not yet patched.

When I have tried to start them for the first time to complete configuration they are not coming up.

In the wrapper.log as well as the system output there is an error messages for incorrect classpath entries in ini.cnf similar to this one:

Classpath entry in ini.cnf not found: /opt/webma/bep/wm20701/common/common/lib/terracotta-toolkit-runtime-ee.jar

I think the issue is with the duplicate common directory but I was not able to locate where this comes from.

All previous installations on Solaris 10 in the last years did not have this issue and the installations were always done by using the same image file.

Any one any ideas what went wrong during installation and how to solve it?



looks like uninstalling and reinstalling the IntegrationServer solves this issue.

I was able to get one out of 5 started and configured after that.

I will check the other 4 in the next days. I already have reinstalled them.

Reinstalling was quite fast as I had saved the installer scripts during the first installations.


1 Like

Hi Holger,

Was there a solution to the issue faced?
Reinstalling sound more of a work around.

Hi Bari,

we have finally managed to install all our installations.

Except for one MWS which is failing during applying the Fixes and never comes after that.
We have tried reinstalling several times and we also have SAG support involved meanwhile.

I think that this might be due to some differences between Solaris 10 and Solaris 11 but I will follow up on this next year.


Check the dir path , where you have installed product.

Extended settings

May be homeDir path is not correct , hence IS is not coming up.

Hi Shahbaz,

as this is still wM 9.5 there is no instances/default directory available.

This one has been introduced by wM 9.6.

The mentioned Installations are 5 independent installation in 5 different home dirs.