Fail to connect to Integration Server

Good day,

We installed several Integration servers that are fully functional and without issues according to the logs. When trying to setup connections to these servers from my webMethods server, only a few appear available.

The issue appears when doing http://server:5555/soap/rpc and the error is

----------

Authentication of user “null” failed with exception: com.softwareag.security.jaas.principals.SagGeneralSecurityException: Exception while parsing assertion com.softwareag.security.jaas.principals.SagGeneralSecurityException: SagGeneralSecurityException while parsing assertion com.softwareag.security.jaas.principals.SagGeneralSecurityException: SAML assertion already expired.

----------

It appears that user is null due to the SAML misprocessing …

None of the servers points to SAML url in Settings/Resources, and when configuring it for the failed server, no difference recorded.

Servers are running, and firewalls rules configured.

All users are exactly the same on all servers, data source is configured on MWS and Central User configuration is configured.

Configuring Monitor does not make difference.

All components are the same and on the same fix level.

All servers are commercially licensed.

Noting all these issues above as mentioned in most of the responses on this subject.

Will greatly appreciate an advise.

Thank you in advance

Leonard

Leonard, I’ve seen this error with SPM on 9.12 version. Try restarting the SPM and see if the error goes away.

If that doesn’t work, backup the profiles directory and recreate the OSGI profiles. If you have made changes to the wrapper config files, restore them from the backup after recreating the profiles.

I hope this helps.

KM

Thank you Kasi, restarting SPM magically enabled one server but remaining three are still no avail. I cannot pickup the difference between the avail and not avail servers when checking the environment and configurations …

By recreating OSGi profile I assume you mean recreating a server instance, do not you ?

Regards
Leonard

Hi Leonard, please compare the server date and time (including seconds) between IS and MWS installations - are they all in sync? If not, sync them first and see if that resolves the issue.

I meant recreating the MWS OSGI profile using the mws.sh script available under /opt/softwareag/MWS/bin, with the options delete-osgi-profile and create-osgi-profile.

  • mws -s instanceName delete-osgi-profile
  • mws -s instanceName create-osgi-profile

where instanceName is default, for example.
After this, restart MWS, IS and SPM - hopefully this resolves the issue. The “Administering My webMethods Server” guide has more info.

If the issue persists, please reach out to support, before you recreate the IS instances so that the issue can be investigated.

KM

2 Likes

Hi Kasi,

The problem servers appeared over two hours apart from the measuring MWS, and after configuring the other MWS which time is matching these servers I observed perfect connectivity.

Thank you again for your time and effort, much appreciated !!

Leonard

You are most welcome, Leonard - glad that it’s resolved!
Please select a solution for this post, for others’ benefit.

KM

Thank you again Kasi,

Thus sum the solution:

None of the other recommendations I came across and listed in the problem statement are required - just synch the time.

Regards

Leonard

1 Like