Errors when trace is activated (Natural extensions)

I have a Natural program which does a _connect, _process, _commit, _disconnect, each time passing the sessionid and sessionkey. I am using the extensions for Natural library SYSEXSXS. Works fine. I wanted to see what was produced if I turned trace on. Now I get an error INOXHE8285 on the _commit (Invalid Session ID - Session nn is currently executing a different request). If I run the program again the session number is changed, but I get the same error. One trace record gets created each time - for the sxsstoretofile.

If I do a query on my documents using the Tamino Interactive Interface I get INOSXE7045:SXS Trace failed - Transaction was rolled back. The is not returned. When I turn the trace off I have no problems, either with my program or the Tamino Interactive Interface.

Hi Priscilla

There seem to be some problems with SXS-Trace in session context. Hopefully these won’t occur with the next Tamino version.

As long as your server extension works fine without SXS-Trace, you won’t need to use this debug feature either.


Julius Geppert