Error while running opcua gateway locally

I want to run the opcua ua gateway locally on my Windows machine, I am behind a corporate firewall Zscaler which might be causing the issue
I am following the article Simple OPCUA Device Integration - Knowledge base / Blog - Cumulocity IoT - Software AG Tech Community & Forums
when I ran the command
java -jar opcua-device-gateway-1014.0.408-SNAPSHOT.jar,development
I am getting below error

Error message:
Caused by: PKIX path building failed: unable to find valid certification path to requested target at java.base/ at java.base/ at java.base/ at java.base/ at java.base/ at java.base/ at java.base/$T13CertificateConsumer.checkServerCerts( ... 47 common frames omitted Caused by: unable to find valid certification path to requested target at java.base/ at java.base/ at java.base/ at java.base/ ... 53 common frames omitted

any suggestions how to tackle it I have a signed certificate available with me

Hello Rushikesh,

you are using an older snapshot version of the OPC UA Gateway, could you please try a new released version: Index of /examples/opc-ua/

If this problem still exists, could you please share the complete log. This would help me to investigate why the gateway has problems with certificate.

Best regards,

Alexander Pester

Hii I am getting below output when I ran the program using released version: Index of /examples/opc-ua/

2023-11-16 12:19:10.656  INFO 100986 --- [   scheduler-11] c.c.o.c.g.m.HttpPostQueue                : Queue buffer size: 0/25000
2023-11-16 12:19:13.557  INFO 100986 --- [   scheduler-10] c.c.o.c.g.v.ValueMapManagerService       : No values are currently known. Skipping persisting value maps
2023-11-16 12:19:13.559  INFO 100986 --- [    scheduler-6] c.c.o.c.g.m.GatewayMonitoringService     : No platform credentials are available. Skipping sending monitoring information.
2023-11-16 12:19:13.559  INFO 100986 --- [    scheduler-2] c.c.o.c.g.m.GatewayMonitoringService     : Items left to flush: Measurements 0, Events 0, Alarms 0, MaxCapacity: 250000
2023-11-16 12:19:13.561  INFO 100986 --- [    scheduler-6] c.c.o.c.g.s.SubscriptionUpdateScheduler  : Update subscriptions for knowing servers
2023-11-16 12:19:13.561  INFO 100986 --- [    scheduler-6] c.c.o.c.g.s.SubscriptionUpdateScheduler  : Platform credentials are not available yet, skip updating subscription and will check again in the next round
2023-11-16 12:19:14.330  INFO 100986 --- [    scheduler-1] c.c.o.c.g.b.service.BootstrapService     : Polling device credentials...
2023-11-16 12:19:14.331  INFO 100986 --- [    scheduler-1] c.c.o.c.g.b.service.BootstrapService     : Credentials is not available locally or bootstrap is forced, polling from server..
2023-11-16 12:19:14.337 ERROR 100986 --- [    scheduler-1] o.s.s.s.TaskUtils$LoggingErrorHandler    : Unexpected error occurred in scheduled task Name or service not known
        at org.glassfish.jersey.apache.connector.ApacheConnector.apply(
        at org.glassfish.jersey.client.ClientRuntime.invoke(
        at org.glassfish.jersey.client.JerseyInvocation.lambda$invoke$0(
        at org.glassfish.jersey.client.JerseyInvocation.lambda$runInScope$3(
        at org.glassfish.jersey.internal.Errors.process(
        at org.glassfish.jersey.internal.Errors.process(
        at org.glassfish.jersey.internal.Errors.process(
        at org.glassfish.jersey.process.internal.RequestScope.runInScope(
        at org.glassfish.jersey.client.JerseyInvocation.runInScope(
        at org.glassfish.jersey.client.JerseyInvocation.invoke(
        at org.glassfish.jersey.client.JerseyInvocation$Builder.method(
        at org.glassfish.jersey.client.JerseyInvocation$
        at com.cumulocity.sdk.client.RestConnector.httpPost(
        at com.cumulocity.sdk.client.devicecontrol.DeviceCredentialsApiImpl.pollCredentials(
        at com.cumulocity.opcua.client.gateway.bootstrap.service.BootstrapService.pollDeviceCredentials(
        at com.cumulocity.opcua.client.gateway.bootstrap.service.BootstrapService.lambda$scheduleDeviceCredentialsPoll$0(
        at java.base/java.util.concurrent.Executors$
        at java.base/java.util.concurrent.FutureTask.runAndReset(
        at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
        at java.base/java.util.concurrent.ThreadPoolExecutor$
        at java.base/
Caused by: Name or service not known
        at java.base/ Method)
        at java.base/$PlatformNameService.lookupAllHostAddr(
        at java.base/
        at java.base/$NameServiceAddresses.get(
        at java.base/
        at java.base/
        at java.base/
        at org.apache.http.impl.conn.SystemDefaultDnsResolver.resolve(
        at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(
        at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(
        at org.apache.http.impl.execchain.MainClientExec.establishRoute(
        at org.apache.http.impl.execchain.MainClientExec.execute(
        at org.apache.http.impl.execchain.ProtocolExec.execute(
        at org.apache.http.impl.execchain.RetryExec.execute(
        at org.apache.http.impl.execchain.RedirectExec.execute(
        at org.apache.http.impl.client.InternalHttpClient.doExecute(
        at org.apache.http.impl.client.CloseableHttpClient.execute(
        at org.glassfish.jersey.apache.connector.ApacheConnector.apply(
        ... 24 common frames omitted

The hostname can’t be resolved by your DNS.

Do you have an IP address? If yes check the IP address, if you can reach it from your local machine you can add this to your local host file. If not, please check with the IT/infrastructure department how you can reach that host